nyoj269VF



/*VF
时间限制:1000 ms  |  内存限制:65535 KB
难度:2
描述
Vasya is the beginning mathematician. He decided to make an important contribution to
the science and to become famous all over the world. But how can he do that
if the most interesting facts such as Pythagor’s theorem are already proved?
Correct! He is to think out something his own, original.
So he thought out the Theory of Vasya’s Functions.
Vasya’s Functions (VF) are rather simple: the value of the Nth VF in the point S is
an amount of integers from 1 to N that have the sum of digits S.
You seem to be great programmers, so Vasya gave you a task to find the milliard VF
value (i.e. the VF with N = 109) because Vasya himself won’t cope with the task.
Can you solve the problem?

输入There are multiple test cases.
 Integer S (1 ≤ S ≤ 81).输出The milliard VF value in the point S.样例输入1
样例输出10*/

 

<span style="font-size:18px;">#include <stdio.h>   
int dp[10][82];  
  
void func()  
{  
    int i,j,k;  
    for(i = 1; i < 10; i++)  
    {  
        dp[1][i] = 1;  
    }  
    for(i = 2; i < 10; i++)  
    {  
        for(j = 1; j <= 9*i; j++)  
        {  
            for(k = 0; k <= 9&&k < j; k++)  
            {  
                dp[i][j] += dp[i-1][j-k];  
            }  
        }  
    }  
}  
int main()  
{  
    int s,i;  
    func();  
    while(~scanf("%d",&s))  
    {  
        int count = 0;  
        if(s == 1)  
        {  
            printf("%d\n",10);  
            continue;  
        }  
        else  
        {  
            for(i = 1; i < 10; i++)              {  
                count += dp[i][s];  
            }  
        }  
        printf("%d\n",count);  
    }  
    return 0;  
} 
</span>

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值