nyoj269 VF

VF

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
Vasya is the beginning mathematician. He decided to make an important contribution to the science and to become famous all over the world. But how can he do that if the most interesting facts such as Pythagor’s theorem are already proved? Correct! He is to think out something his own, original. So he thought out the Theory of Vasya’s Functions. Vasya’s Functions (VF) are rather simple: the value of the  N th VF in the point  S is an amount of integers from 1 to  N that have the sum of digits  S. You seem to be great programmers, so Vasya gave you a task to find the milliard VF value (i.e. the VF with  N = 10 9) because Vasya himself won’t cope with the task. Can you solve the problem?
输入
There are multiple test cases.
Integer S (1 ≤ S ≤ 81).
输出
The milliard VF value in the point S.
样例输入
1
样例输出
10
/*
输入一个数s,求1-10^9中,每个数的各位数字之和为s的数有几个;
dp[i][j]表示前 j 位数字之和为 i 的情况的数量;
当i>1时,假设第j位为k,那么前j-1的和就是i-k;
由此得出状态转移方程dp[i][j]=dp[i][j]+dp[i-k][j-1].
*/
#include<stdio.h>
int dp[85][15];
int i,j,k;
//求1-1000000000中各位数字和相加等于s的个数   有点像超级台阶那种递归 
int main()
{
	for(i=0;i<10;i++)//初始化 
		dp[0][i]=1;//数字之和为0,且位数为i的数字个数 
		
	for(i=1;i<82;i++)//数字之和最大是81 9位9 
		for(j=1;j<10;j++)//前j位之和为i 
			for(k=0;k<10&&i-k>=0;k++)//第j位为k,让前j-1位之和为i-k 
			{	
				if(dp[i-k][j-1])//如果前面的数字能够组合成i-k 
				dp[i][j]+=dp[i-k][j-1];
			}
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==1)
		printf("10\n");//1,10,100,1000...100000000 
		else
		printf("%d\n",dp[n][9]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值