NYOJ 269 VF

VF

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
Vasya is the beginning mathematician. He decided to make an important contribution to the science and to become famous all over the world. But how can he do that if the most interesting facts such as Pythagor’s theorem are already proved? Correct! He is to think out something his own, original. So he thought out the Theory of Vasya’s Functions. Vasya’s Functions (VF) are rather simple: the value of the  N th VF in the point  S is an amount of integers from 1 to  N that have the sum of digits  S. You seem to be great programmers, so Vasya gave you a task to find the milliard VF value (i.e. the VF with  N = 10 9) because Vasya himself won’t cope with the task. Can you solve the problem?
输入
There are multiple test cases.
Integer S (1 ≤ S ≤ 81).
输出
The milliard VF value in the point S.
样例输入
1
样例输出
10
动态规划!
如果找不到状态转移方程,直接递归求值,再打表!别怕麻烦哦!
递归代码:
#include<stdio.h>
#include<string.h>
#define M 1000000000
__int64 num[85];
void fun(__int64 a,__int64 sum,__int64 m)
{
	if(sum>M)
		return;
	__int64 i;
	num[m]++;
	for(i=0;i<=9;i++)
	{
		fun(i,sum*10+i,m+i);
	}
}
int main()
{
	__int64 n,i;
	memset(num,0,sizeof(num));
	for(i=1;i<=9;i++)
	{
		fun(i,i,i);
	}
	while(~scanf("%I64d",&n))
	{
		printf("%I64d\n",num[n]);
	}
	return 0;
}

打表:
AC码:
#include<stdio.h>
int f[82]={1,10,45,165,495,1287,3003,6435,12870,24310,43749,75501,125565,202005,315315,478731,708444,1023660,1446445,2001285,2714319,3612231,4720815,6063255,7658190,9517662,11645073,14033305,16663185,19502505,22505751,25614639,28759500,31861500,34835625,37594305,40051495,42126975,43750575,44865975,45433800,45433800,44865975,43750575,42126975,40051495,37594305,34835625,31861500,28759500,25614639,22505751,19502505,16663185,14033305,11645073,9517662,7658190,6063255,4720815,3612231,2714319,2001285,1446445,1023660,708444,478731,315315,202005,125565,75501,43749,24310,12870,6435,3003,1287,495,165,45,9,1};
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		printf("%d\n",f[n]);
	}
	return 0;
}

动态规划!
AC码:
#include<stdio.h>
int dp[10][82];
void DP()
{
	int i,j,k;
	for(i=1;i<10;i++)
		dp[1][i]=1;
	for(i=1;i<10;i++)
	{// i表示有i位数字时
		for(j=1;j<=9*i;j++)
		{// j表示变化范围,当有i位数时,j的范围[1,9*i]
			for(k=0;k<10&&k<=j;k++)
			{
				dp[i][j]+=dp[i-1][j-k];
			}
		}
	}
}
int main()
{
	int n,i,ans;
	DP();
	while(~scanf("%d",&n))
	{
		if(n==1)
			printf("10\n");
		else
		{
			ans=0;
			for(i=1;i<10;i++)
				ans+=dp[i][n];
			printf("%d\n",ans);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值