题目描述
学习KMP算法,给出主串和模式串,求模式串在主串的位置
提示:为什么next值和课本的不一样???
输入
第一个输入t,表示有t个实例
第二行输入第1个实例的主串,第三行输入第1个实例的模式串
以此类推
输出
第一行输出第1个实例的模式串的next值
第二行输出第1个实例的匹配位置,位置从1开始计算,如果匹配成功输出位置,匹配失败输出0
以此类推
输入输出样例
输入样例1 <-复制
3
qwertyuiop
tyu
aabbccdd
ccc
aaaabababac
abac
输出样例1
-1 0 0
5
-1 0 1
0
-1 0 0 1
8
AC代码
#include<iostream>
#include<string>
using namespace std;
void getnext(string t, int next[])
{
int i = 0;
next[0] = -1;
int j = -1;
while (i < t.length()-1)
{
if (j == -1 || t[i] == t[j])
{
i++;
j++;
next[i] = j;
}
else
j = next[j];
}
}
int zhao(string s, string t,int next[])
{
int i = 0, j = 0;
int lens = s.length(), lent = t.length();
while (i<lens && j< lent)
{
if (j == -1 || s[i] == t[j])
{
i++; j++;
}
else
j = next[j];
}
if (j > t.length() - 1)
return i - t.length() + 1;
return 0;
}
int main()
{
int q;
cin >> q;
string s, t;
int i;
int next[20];
while (q--)
{
cin >> s >> t;
getnext(t,next);
for (i = 0; i <t.length(); i++)
{
cout << next[i] << " ";
if (i == t.length()-1)
cout << endl;
}
cout << zhao(s, t, next) << endl;
}
}
(by 归忆)