题目描述
使用C++的STL堆栈对象,编写程序实现行编辑功能。行编辑功能是:当输入#字符,则执行退格操作;如果无字符可退就不操作,不会报错
本程序默认不会显示#字符,所以连续输入多个#表示连续执行多次退格操作
每输入一行字符打回车则表示字符串结束
注意:必须使用堆栈实现,而且结果必须是正序输出
输入
第一行输入一个整数t,表示有t行字符串要输入
第二行起输入一行字符串,共输入t行
输出
每行输出最终处理后的结果,如果一行输入的字符串经过处理后没有字符输出,则直接输出NULL
输入输出样例
输入样例1 <-复制
4
chinaa#
sb#zb#u
##shen###zhen###
chi##a#####
输出样例1
china
szu
sz
NULL
AC代码
#include<iostream>
#include<string>
#include<stack>
using namespace std;
int main()
{
int t;
cin >> t;
while (t--)
{
stack <char> s;
string chuan;
cin >> chuan;
int len = chuan.length();
int i;
for (i = 0; i < len; i++)
{
if (chuan[i] == '#' && !s.empty())
s.pop();
else if(chuan[i]!='#')
s.push(chuan[i]);
}
i = 0;
if (s.empty())
{
cout << "NULL" << endl;
continue;
}
while (!s.empty())
{
chuan[i++] = s.top();
s.pop();
}
string chuan2 = chuan.substr(0, i);
chuan2 = string(chuan2.rbegin(), chuan2.rend());
cout << chuan2 << endl;
}
}
(by 归忆)