poj 2240 Arbitrage bellman-ford算法

25 篇文章 0 订阅
22 篇文章 0 订阅

点击打开链接

Arbitrage
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13434 Accepted: 5657

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No
题目大意:给你几种货币的名字,还有货币之间的汇率,问你是否通过兑换使货币数量增加

bellmanford或者spfa计算是否有负圈回路

#include<stdio.h>
#include<string>
#include<map>
#include<iostream>
using namespace std;
double g[31][31];
double dis[31];
int n;
bool bellman()
{
	int i, j, k;
	for(i = 0; i < 31; i++)
		dis[i] = 1;
	for(i = 1; i < n; i++)
	{
		for(j = 1; j <= n; j++)
		{
			for(k = 1; k <= n; k++)
			{
				if(dis[k] < dis[j] * g[j][k])
					dis[k] = dis[j] * g[j][k];
			}
		}
	}
	for(j = 1; j <= n; j++)
	{
		for(k = 1; k <= n; k++)
		{
			if(dis[k] < dis[j] * g[j][k])
				return 0;
		}
	}
	return 1;
}
int main()
{
	int m, t = 1;
	while(scanf("%d", &n), n != 0)
	{
		int i;
		string str;
		map<string, int> ma;
		for(i = 1; i <= n; i++)
		{
			cin>>str;
			ma[str] = i;
		}
		scanf("%d", &m);
		double rate;
		string str2;
		while(m--)
		{
			cin>>str>>rate>>str2;
			g[ma[str]][ma[str2]] = rate;
		}
		if(bellman() == 0)
			printf("Case %d: Yes\n", t);
		else
			printf("Case %d: No\n", t);
		ma.clear();
		t++;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

勇敢的炮灰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值