poj 1002 487-3279

点击打开链接

487-3279
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 220260 Accepted: 38393

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 
D, E, and F map to 3 
G, H, and I map to 4 
J, K, and L map to 5 
M, N, and O map to 6 
P, R, and S map to 7 
T, U, and V map to 8 
W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

题目大意:按照题目给的字母对应方法把输入的字母转化成数字,然后号码大小排序并且按格式输出

方法有2种,一种是建立哈希表每个号码出现的次数,用vector记录字符串,最后sort一下vector然后输出就可以了,这算是比较笨的方法,如果号码再多点就存不下了,比较占内存

#include<stdio.h>
#include<iostream>
//#include<set>
#include<algorithm>
#include<string>
#include<vector>
using namespace std;

int myhash[] = {2, 2, 2, 3, 3, 3, 4, 4, 4, 5, 5, 5, 6, 6, 6, 7, 0, 7, 7, 8, 8, 8, 9, 9, 9};
int _hash[10][10][10][10][10][10][10];
vector<string> v;
int main()
{
//	freopen("test.txt", "r", stdin);
//	memset(_hash, 0, sizeof(_hash));
	string str;
	char str2[150];
	int num;
	int t;
	scanf("%d", &num);
	while(num--)
	{
		scanf("%s", str2);
		int i;
		for(i = 0; str2[i]; i++)
		{ 
			if(str2[i] >='0' && str2[i] <= '9')
				str += str2[i];
			else if(str2[i] >= 'A' && str2[i] < 'Z')
			{
				str += myhash[str2[i] - 'A'] + '0';
			}
				
		}
		while(str.length() < 7)
		{
			str = '0' + str;
		}
		if(_hash[str[0] - '0'][str[1] - '0'][str[2] - '0'][str[3] - '0'][str[4] - '0'][str[5] - '0'][str[6] - '0'] == 0)
		{
			v.push_back(str);
		}
		_hash[str[0] - '0'][str[1] - '0'][str[2] - '0'][str[3] - '0'][str[4] - '0'][str[5] - '0'][str[6] - '0'] ++;
		str = "";
	}
	sort(v.begin(), v.end());
	vector<string>::iterator p;
	int flag = 0;
	for(p = v.begin(); p != v.end(); p++)
	{
		t = _hash[(*p)[0] - '0'][(*p)[1] - '0'][(*p)[2] - '0'][(*p)[3] - '0'][(*p)[4] - '0'][(*p)[5] - '0'][(*p)[6] - '0'];
		if(t > 1)
		{
			printf("%s-%s %d\n", (*p).substr(0, 3).c_str(), (*p).substr(3, 4).c_str(), t); 
			flag = 1;
		}
	}
	if(flag == 0)
		printf("No duplicates.");
	return 0;
}

另一种就是使用stl的map,直接数字和数字对应,这题一下就没难度了,而且无论字符串多长都可以做,map改成字符串和数字对应就行了,如果不让用stl而且字符串又比较长,可以自己写一个二分查找树,我的水平也就能写个这种树了,更高级的也不会。。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <set>
#include <map>

using namespace std;

int num[] = 
{
	2, 2, 2,
	3, 3, 3,
	4, 4, 4,
	5, 5, 5,
	6, 6, 6,
	7, 0, 7, 7,
	8, 8, 8,
	9, 9, 9
};

map<int, int> s;
char buf[128];

int main()
{
	int t;
	scanf("%d", &t);
	bool flag = false;
	for(int i = 0; i < t; i++)
	{
		scanf("%s", &buf);
		int c = 0;
		for(int j = 0; buf[j]; j++)
		{
			if(isdigit(buf[j]))
				c = c * 10 + buf[j] - '0';
			else if(isalpha(buf[j]))
				c = c * 10 + num[ buf[j] - 'A' ];
		}
		s[c]++;
	}
	for(map<int, int>::iterator it = s.begin(); it != s.end(); it++)
		if(it->second > 1)
		{
			flag = true;
			printf("%03d-%04d %d\n", it->first / 10000, it->first % 10000, it->second);
		}
	if(!flag)
		puts("No duplicates.");
return 0;
}
        


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

勇敢的炮灰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值