1110. Complete Binary Tree

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line "YES" and the index of the last node if the tree is a complete binary tree, or "NO" and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:
9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -
Sample Output 1:
YES 8
Sample Input 2:
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -
Sample Output 2:

NO 1

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <deque>
#include <queue>
#include <cstring>
#include <vector>
#include <string>
#include <iomanip>
#include <map>
#include <set>
#include <cmath>
#include <stack>
#include <cmath>
#include <algorithm>
using namespace std;
#define max1 10010
struct tree
{
int right=-1,left=-1;
};
int main() {
int n,i;
cin>>n;
    vector<tree>p(n);
    vector<bool>isRoot(n,true);
    for(i=0;i<n;i++)
{
string l,r;
        cin>>l>>r;
        if(l[0]!='-')
        {
            int left=atoi(l.c_str());
            p[i].left=left;
            isRoot[left]=false;
        }
        if(r[0]!='-')
        {
            int right=atoi(r.c_str());
            p[i].right=right;
            isRoot[right]=false;
        }
}
int root;
for(i=0;i<n;i++)
{
if(isRoot[i])
{
root=i;
break;
}
}
queue<int>g;
g.push(root);
int temp,last,count=0;
while(!g.empty())
{
temp=g.front();
if(temp==-1)
break;
g.pop();
last=temp;
count++;
g.push(p[temp].left);
g.push(p[temp].right);
}
if(count!=n)
cout<<"NO"<<' '<<root;
else
cout<<"YES"<<' '<<last;
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值