POJ 3278 Catch That Cow (bfs)

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 95484 Accepted: 29934

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意:农夫在位置n,他可以走x-1,x+1,2*x.最小走多少步可以找到位置在k的牛

做法:bfs

要注意的地方有两个,边界条件,和结构体的入队。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
#define MAX_N 100010
struct john
{
	int x;
	int t;
};



int main()
{
	int n,k;
	while (cin >> n >> k) 
	{
		if (n >= k)     //比他小的情况和等于的情况直接就可以求出来了
		{
			cout << n-k<< endl;
			continue;
		}
		//初始化
		queue<john>q;
		john start;
		int v[MAX_N] = {0};
		start.x = n;
		start.t = 0;
		v[n] = 1;
		q.push(start);


		while (!q.empty())
		{
			if (q.front().x == k)break;//找到就退出去
			if (q.front().x + 1 < MAX_N) {   //边界一定要考虑 不然会runtime error
				if (v[q.front().x + 1] == 0)
				{
					john temp;//要重新定义一个变量  因为queue的对象是引用,如果不重新定义,会修改了队列里的数据
					v[q.front().x + 1] = 1;
					temp.x = q.front().x + 1;
					temp.t = q.front().t + 1;
					q.push(temp);
				}
			}
			if (q.front().x - 1 >= 0) {
				if (v[q.front().x - 1] == 0)
				{
					john temp;
					v[q.front().x - 1] = 1;
					temp.x = q.front().x - 1;
					temp.t = q.front().t + 1;
					q.push(temp);
				}
			}
			if (q.front().x * 2 < MAX_N)
			{
				if(v[q.front().x * 2] == 0)
				{
					john temp;
					v[q.front().x * 2] = 1;
					temp.x = q.front().x * 2;
					temp.t = q.front().t + 1;
					q.push(temp);
				}
			}
			q.pop();

		}
		cout << q.front().t << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值