HDU1016:Prime Ring Problem(DFS)

dfs培养的是一种思维,
简单点来说用dfs做最短路一般会超时,所以更多会要是思维的训练

Prime Ring Problem
Time Limit: 2000msMemory Limit: 32768KB This problem will be judged on HDU. Original ID: 1016
64-bit integer IO format: %I64d Java class name: Main
Prev Submit Status Statistics Next
Type:
None

Tag it!
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
这题说形成素数环,其实可看为,后一位的前两位相加为素数,一直查找到n+1位;

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int prime[100] = {0,0,1};
int n;
int b[100];
int stu[100];
int k = 0;
void dfs(int depth)
{
    if (depth == n + 1 && prime[b[1] + b[n]])
    {

        for (int i = 1; i <= n; i++)
        {
            if (i == 1)
                cout << b[i];
            else
                cout << " " << b[i];
        }
        puts("");
        return;
    }
    for (int i = 2; i <= n; i++)
    {
        if (!stu[i] && prime[i + b[depth - 1]])
        {
            stu[i] = 1;
            b[depth] = i;
            dfs(depth + 1);
            stu[i] = 0;
        }
    }
}
int main()
{
     //prime
    int i, j;
    for (i = 3; i < 100; i++)
    {
        prime[i++] = 1;
        prime[i] = 0;
    }
    for (i = 3; i < 100; i++)
        for (j = i + i; j < 100; j += i)
            prime[j] = 0;
    //int k = 0;
    while (cin>>n)
    {
        printf("Case %d:\n", ++k);
    //  puts("");
        memset(stu, 0, sizeof(stu));
        b[1] = 1;
        stu[1] = 1;
        dfs(2);
        puts("");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值