动态规划C - Max Sum HDU - 1003

Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6
import org.omg.PortableInterceptor.SYSTEM_EXCEPTION;

import java.util.ArrayList;
import java.util.Scanner;

/**
 * Created by 95112 on 10/23/2017.
 */
public class MaxSum {
    public static void main(String[] args)
    {
        Scanner scanner = new Scanner(System.in);
        ArrayList<ArrayList<String>> answers = new ArrayList<>();
        int n;
        n = scanner.nextInt();
        for (int i = 0 ; i < n ; i ++)
        {
            ArrayList<String> answer = new ArrayList<>();
            answer.add("Case "+(i+1)+":");
            int amount = scanner.nextInt();
            int[] input = new int[amount];
            for (int j = 0 ; j < amount; j++)
                input[j] = scanner.nextInt();
            int start = 0;
            int end;
            int answerStart= 0;
            int answerEnd= 0;
            int answerSum = Integer.MIN_VALUE;
            int sum = 0;
            for (int j = 0 ; j < amount; j++) {
                sum += input[j];
                if (sum > answerSum) {
                    answerSum = sum;
                    answerStart = start+1;
                    answerEnd = j+1;

                }
                if (sum < 0) {
                    sum = 0;
                    start = j + 1;
                }
            }
            answer.add(answerSum+" "+answerStart+" "+answerEnd);
            answers.add(answer);
        }
        int i = 0;
        for (ArrayList<String> answer : answers){
            for (String a : answer)
                System.out.println(a);
            if (i< answers.size()-1)
                System.out.println("");
            i++;
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值