YTU---2507-李白打酒(DFS)

2507: 李白打酒

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 132   Solved: 79
[ Submit][ Status][ Web Board]

Description

话说大诗人李白,一生好饮。幸好他从不开车。
一天,他提着酒壶,从家里出来,酒壶中有酒2斗。他边走边唱:
    无事街上走,提壶去打酒。
    逢店加一倍,遇花喝一斗。
这一路上,他一共遇到店m次,遇到花n次,已知最后一次遇到的是花,他正好把酒喝光了。 
请你计算李白遇到店和花的次序,可以把遇店记为a,遇花记为b。
例如:这一路上,他一共遇到店5次,遇到花10次,已知最后一次遇到的是花,他正好把酒喝光了。则:babaabbabbabbbb 就是合理的次序。像这样的答案一共有多少呢?请你计算出所有可能方案的个数(包含题目给出的)。

Input

 输入一个整数T,包括T组数据,每组数据包括遇到店的次数m,花的次数n。

Output

 对于每组数据,输出李白遇到店和花的可能次序的个数。

Sample Input

1
5 10

Sample Output

14

HINT

答案是个整数。






AC code:

#include <iostream>
#include <cmath>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define size 10001
using namespace std;
int ans;

void DFS(int store,int flower,int alc,int last)
{
    if(store==0 && flower==0)
        if(alc == 0 && last == 1)
        {
            ans++;
            return;
        }
    if(store > 0)
    {
        DFS(store-1,flower,alc*2,0);
    }
    if(flower > 0 && alc>0)
    {
        DFS(store,flower-1,alc-1,1);
    }
}
int main()
{
    int n;
    cin>>n;
    int a,b;
    while(n--)
    {
        ans=0;
        cin>>a>>b;
        DFS(a,b,2,0);
        cout<<ans<<endl;
    }
    return 0;
}


DFS的简单运用。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值