POJ---3278-Catch That Cow(BFS/deque)

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 40350 Accepted: 12560

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


AC CODE:
#include <iostream>
#include <deque>
#define MAX 100000
using namespace std;
struct ss
{
	int n;  // 记录当前坐标
	int time; // 记录当前已走步数
};
int main()
{
	int aim;
	ss a;
	while(cin>>a.n>>aim)
	{
		deque<ss> q;
		bool use[MAX+1]={0};  //情况打表防重复
		a.time=0;
		q.push_back(a);     // 压入队尾初始状态
		ss present=q.front();   // 队头提出初始状态
		q.pop_front();      // 删除队头
		while(present.n!=aim)   // 当前未找到目标
		{
			ss t;           // 压入中转站
			t.time=present.time+1;  // 步数为当前加1
			t.n=present.n-1;    //坐标改变
			if(t.n>=0&&t.n<=MAX)  // 判断坐标是否满足条件
			{
				if(!use[t.n])   // 是否重复到达
				{
					q.push_back(t);  // 满足条件且不重复到达就压入队尾
					use[t.n]=true;
				}
			}
			t.n=present.n+1;
			if(t.n>=0&&t.n<=MAX)
			{
				if(!use[t.n])
				{
					q.push_back(t);
					use[t.n]=true;
				}
			}
			t.n=present.n<<1;
			if(t.n>=0&&t.n<=MAX)
			{
				if(!use[t.n])
				{
					q.push_back(t);
					use[t.n]=true;
				}
			}
			present=q.front(); // 队头提出
			q.pop_front();	// 删除队头
		}
		cout<<present.time<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值