HDU---5441-Travel(并查集)(2015 Changchun)

42 篇文章 0 订阅
24 篇文章 0 订阅

Travel

Problem Description
Jack likes to travel around the world, but he doesn’t like to wait. Now, he is traveling in the Undirected Kingdom. There are n  cities and  m bidirectional roads connecting the cities. Jack hates waiting too long on the bus, but he can rest at every city. Jack can only stand staying on the bus for a limited time and will go berserk after that. Assuming you know the time it takes to go from one city to another and that the time Jack can stand staying on a bus is  x  minutes, how many pairs of city  (a,b)  are there that Jack can travel from city  a  to  b  without going berserk?
 

Input
The first line contains one integer T,T5 , which represents the number of test case.

For each test case, the first line consists of three integers  n,m  and  q  where  n20000,m100000,q5000 . The Undirected Kingdom has  n cities and  m  bidirectional roads, and there are  q  queries.

Each of the following  m  lines consists of three integers  a,b  and  d  where  a,b{1,...,n}  and  d100000 . It takes Jack  d  minutes to travel from city  a  to city  b  and vice versa.

Then  q  lines follow. Each of them is a query consisting of an integer  x  where  x  is the time limit before Jack goes berserk.

 

Output
You should print  q  lines for each test case. Each of them contains one integer as the number of pair of cities (a,b)  which Jack may travel from  a  to  b  within the time limit  x .

Note that  (a,b)  and  (b,a)  are counted as different pairs and  a  and  b  must be different cities.
 

Sample Input
  
  
1 5 5 3 2 3 6334 1 5 15724 3 5 5705 4 3 12382 1 3 21726 6000 10000 13000
 

Sample Output
  
  
2 6 12
#include <iostream>
#include <cstring>
#include <vector>
#include <queue>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
#define cin1(x) scanf("%d",&x)
#define cin2(x,y) scanf("%d%d",&x,&y)
#define cin3(x,y,z) scanf("%d%d%d",&x,&y,&z)
#define ccout(x) printf("%d\n",x)
int n,m,q,T,sum_val;
int set[20005],sum_set[20005];
struct Road
{
    int a,b,val;
    Road(int x,int y,int z):a(x),b(y),val(z) {}
    friend bool operator<(Road x,Road y)
    {
        return x.val<y.val;
    }
};
struct Question
{
    int num,poi;
    friend bool operator<(Question x, Question y)
    {
        return x.poi<y.poi;
    }
} que[6005];
int ans[6005];
int set_find(int x)
{
    if(set[x]==-1)return x;
    return set[x]=set_find(set[x]);
}
void set_friend(int x,int y)
{
    x=set_find(x);
    y=set_find(y);
    if(x!=y)
    {
        set[x]=y;
        sum_val-=sum_set[x]*(sum_set[x]-1)+sum_set[y]*(sum_set[y]-1);
        sum_set[y]+=sum_set[x];
        sum_set[x]=0;
        sum_val+=sum_set[y]*(sum_set[y]-1);
    }
}
vector<Road> all_road;
void mem_val()
{
    all_road.clear();
    for(int i=0; i<=n; ++i)
    {
        set[i]=-1;
        sum_set[i]=1;
    }
    memset(ans,0,sizeof(ans));
}
int main()
{
    cin1(T);
    int i,j,k,l,x,y,z;
    while(T--)
    {
        cin3(n,m,q);
        mem_val();
        for(i=0; i<m; ++i)
        {
            cin3(x,y,z);
            all_road.push_back(Road(x,y,z));
        }
        for(i=0; i<q; ++i)
        {
            cin1(x);
            que[i].poi=x;
            que[i].num=i;
        }
        sort(all_road.begin(),all_road.end());
        sort(que,que+q);

        int nowi=0;
        sum_val=0;
        for(i=0; i<q; ++i)
        {
            while(nowi<m && all_road[nowi].val<=que[i].poi)
            {
                set_friend(all_road[nowi].a,all_road[nowi].b);
                nowi++;
            }
            ans[ que[i].num ]=sum_val;
        }
        for(i=0; i<q; ++i)
        {
            ccout(ans[i]);
        }
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值