POJ-1679-The Unique MST(次小生成树)

48 篇文章 0 订阅

Language:
The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 26364 Accepted: 9419

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

Source




题意:给定一棵树,若有多个MST或无MST则输出Not Unique,否则输出MST大小。


在寻找最小生成树过程中,标记出MST边与非MST边,并求出MST中两点(u,v)之间的最大边MAX[U][V] ,

设非MST中边的集合为P,非MST中边的集合为T;

则寻找其次小生成树只需寻找 用P的边uv替换掉T中的MAX[u][v]后的最小值  即 min(ans+cost[u][v]-MAX[u][v]),

而此题中只需判断是否存在P中边uv等于MAX[u][v](替换边等于最大边)即可,



//#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <iostream>
#include <cstdio>
#include <cmath>
#include <vector>
#include <cstring>
#include <algorithm>
#include <string>
#include <set>
#include <stack>
#include <map>
#include <queue>
#define INF 0x3f3f3f3f
using namespace std;
const int MAXN = 105;
int cost[MAXN][MAXN];
bool vis[MAXN];
bool in_MST[MAXN][MAXN];
int Max_e[MAXN][MAXN];
int lowcost[MAXN];
int pre[MAXN];
int m,n;
int prim()
{
    int ans=0;
    memset(vis,0,sizeof(vis));
    memset(Max_e,0,sizeof(Max_e));
    memset(in_MST,0,sizeof(in_MST));
    vis[0]=1;
    pre[0]=-1;
    for(int i=0; i<n; ++i)
    {
        lowcost[i]=cost[0][i];
        pre[i]=0;
    }
    lowcost[0]=0;
    for(int i=1; i<n; ++i)
    {
        int minc=INF;
        int p=-1;
        for(int j=0; j<n; ++j)
            if(!vis[j] && minc>lowcost[j])
        {
            minc=lowcost[j];
            p=j;
        }
        if(minc==INF)return -1;
        ans+=minc;
        vis[p]=true;
        in_MST[p][ pre[p] ]=in_MST[ pre[p] ][p]=true;
        for(int j=0; j<n; ++j)
        {
            if(vis[j])
            Max_e[j][p]=Max_e[p][j]=max(Max_e[ pre[p] ][j],lowcost[p]);
            if(!vis[j]&&lowcost[j]>cost[p][j])
            {
                lowcost[j]=cost[p][j];
                pre[j]=p;
            }
        }
    }
    return ans;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int x,y,c;
        memset(cost,INF,sizeof(cost));
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; ++i)cost[i][i]=0;
        for(int i=0; i<m; ++i)
        {
            scanf("%d%d%d",&x,&y,&c);
            --x,--y;
            cost[y][x]=cost[x][y]=c;
        }
        int ans=prim();
        if(ans==-1){cout<<"Not Unique!\n";continue;}
        int flag=0;
        for(int i=0; i<n; ++i)
        {
            for(int j=i+1; j<n; ++j)
                if(!in_MST[i][j])
                    if(cost[i][j]==Max_e[i][j])
                    {
                        cout<<"Not Unique!\n";
                        flag=1;
                        break;
                    }
            if(flag)break;
        }
        if(!flag)
        cout<<ans<<endl;
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值