The GCD and LCM

Description

Give you two integers, and calculate their GCD(Greatest Common Divisor) and LCM(Least Common Multiple). If both of them are positive, print the GCD and LCM. If some are invalid(zero or negative), print invalid.

Sample Input 1

2 10

Sample Output 1

2 10

Sample Input 2

14 0

Sample Output 2

invalid

Hint

You may not learn the algorithms of calculating LCM and GCD in your primary school or middle school. So you can serach about them, or read the instruction in wikipedia about Least Common Multiple and Greatest Common Divisor.


#include<iostream>
using namespace std;
int main()
{
	int a, b;
	while (cin >> a >> b)
	{
		if (a > 0 && b > 0)
		{
			if (a%b == 0 || b%a == 0)
			{
				cout << (a > b ? b : a) <<" "<< (a > b ? a : b) << endl;
				continue;
			}
			int i, gcd = 1, n = a > b ? b : a;
			for (i = 1; i <= n; i++)
			{
				if (a%i == 0 && b%i == 0)
					gcd = i;
			}
			cout << gcd << " " << a*b / gcd << endl;
		}
		else
			cout << "invalid" << endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值