POJ 2352 Stars(树状数组)题解

Language:Default
Stars
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 52268
Accepted: 22486

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0


题意:题目会给n个(x,y),并且按照以下顺序依次给出数据:先按y递增,y相同按x递增。要我们给出0~n-1等级的个数,其中等级这样定义:有一个(xi,yi),等级为所有x<=xi && y<=yi(不包括本身)的个数。

思路:树状数组题,因为题目给出的y是递增的,所以我们只要关心当前(x,y)之前小于等于x的个数有多少,就是它的等级了。因为x>=0,我们用的树状数组所以要++。

代码:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cctype>
#include<queue>
#include<cmath>
#include<string>
#include<stack> 
#include<set>
#include<map>
#include<vector>
#include<iostream>
#include<algorithm>
#include<sstream>
#define ll long long 
const int N=32005;
const int INF=1e9;
using namespace std;
int a[N],ans[15005];
int n; 

int lowbit(int x){
	return x&(-x);
}
void update(int x){
	for(int i=x;i<N;i+=lowbit(i)){
		a[i]++;
	}
}
int sum(int x){
	int ans=0;
	for(int i=x;i>=1;i-=lowbit(i)){
		ans+=a[i];
	}
	return ans;
}
int main(){
	int cnt,x,y;
	while(~scanf("%d",&n)){
		memset(a,0,sizeof(a));
		memset(ans,0,sizeof(ans));
		for(int i=0;i<n;i++){
			scanf("%d%d",&x,&y);
			ans[sum(++x)]++;
			update(x);
		}
		for(int i=0;i<n;i++){
			printf("%d\n",ans[i]);
		}
	}
    return 0;  
}  

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值