poj 2352 Stars (树状数组)

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题意

题目为多组数据,每组数据中有n个点代表n个星星,每个点的坐标按照y轴为第一关键字、x轴为第二关键字升序排序给出。以每个星星为起点向x,y轴作垂线,会得到一个矩形,这个矩形里面所包含的星星数(不包括它本身)称为该星星的等级。要求输出在0~n-1等级各有多少个星星。

题解

树状数组或线段树都可以做。树状数组编写简单,果断选用。由于星星的纵坐标是升序排序给出,所以该点之前的所有的点的纵坐标都是小于等于它的,该点所成的矩形就可以通过只维护小于它横坐标有多少个星星来判断等级。每加入一颗星星,先判断它等级,再加入点。注意,横坐标有为0的情况,所以存入时横坐标都要+1。

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int N = 20010;

int n, x, y, a[2 * N], ans[2 * N];

int lowbit(int x) {
    return x & (-x);
}

void add(int i, int delta) {
    while(i <= 32010) {
        a[i] += delta;
        i += lowbit(i);
    }
}

int query(int x) {
    int sum = 0;
    while(x) {
        sum += a[x];
        x -= lowbit(x);
    }
    return sum;
}

int main() {
    while(scanf("%d", &n) != EOF) {
        memset(a, 0, sizeof(a));
        memset(ans, 0, sizeof(ans));
        for(int i = 0; i < n; i ++) {
            scanf("%d %d", &x, &y);
            int tmp = query(x + 1);
            ans[tmp] ++;
            add(x + 1, 1);
        }
        for(int i = 0; i < n; i ++)
            printf("%d\n", ans[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值