最大流 ( Dinic -- 时间都去哪了???)

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
Output
For each test cases, you should output the maximum flow from source 1 to sink N.
Sample Input
2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1
Sample Output
Case 1: 1
Case 2: 2

//maxn 少开4个0 200ms
//ll 换成 int 200ms
//cin 换成 scanf 200ms

#pragma warning(disable:4996)
#include"iostream"
#include"functional"
#include"algorithm"
#include"string"
#include"string.h"
#include"stack"
#include"cmath"
#include"queue"
#include"vector"
#include"map"
using namespace std;
const int inf = 1e9;
const int maxn = 3500;
typedef struct node {
	int to, w, nex;
}node;
int head[maxn], dis[maxn];
node g[maxn];
int cnt;
void innit() {
	cnt = -1;
	memset(head, -1, sizeof(head));
	memset(g, 0, sizeof(g));
}

void add(int a, int b, int c) {
	cnt++;
	g[cnt].to = b;
	g[cnt].w = c;
	g[cnt].nex = head[a];
	head[a] = cnt;
}

bool bfs(int st, int ed) {
	queue<int> s;
	memset(dis, -1, sizeof(dis));
	dis[st] = 0;
	s.push(st);
	while (!s.empty()) {
		int k = s.front();
		s.pop();
		for (int i = head[k]; i != -1; i = g[i].nex) {
			int to = g[i].to;
			if (dis[to] == -1 && g[i].w) {
				dis[to] = dis[k] + 1;
				s.push(to);
			}
		}
	}
	return dis[ed] != -1;
}

int dfs(int st, int ed, int maxflow) {
	if (st == ed) return maxflow;
	int ans = 0;
	for (int i = head[st]; i != -1; i = g[i].nex) {
		int to = g[i].to;
		if (dis[to] == dis[st] + 1 && ans < maxflow) {
			int p = 0;
			if (p = dfs(to, ed, min(maxflow-ans,g[i].w))) {
				ans += p;
				g[i].w -= p;
				g[i ^ 1].w += p;

			}
		}
	}
	return ans;
}

int Dinic(int st, int ed) {
	int ans = 0;
	while (bfs(st, ed)) {
		ans += dfs(st, ed, inf);
	}
	return ans;
}

int main() {
	int a;
	scanf("%d", &a);
	for (int i = 1; i <= a; i++) {
		innit();
		int to, cnt;
		scanf("%d%d", &to, &cnt);
		for (int j = 0; j < cnt; j++) {
			int u, v, t;
			scanf("%d%d%d", &u, &v, &t);
			add(u, v, t);
			add(v, u, 0);
		}
		printf("Case %d: %d\n", i, Dinic(1, to));
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值