POJ 3984-迷宫问题(BFS+回溯路径)

迷宫问题
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7862 Accepted: 4615

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
bfs刷多了。。5分钟敲完1A
#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
using namespace std;
typedef struct node
{
	int x,y,step,pre;
};
node que[100010];
int s,e,ma[10][10],vis[10][10],ansx[100010],ansy[100010];
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
void bfs()
{
	s=0;e=0;int pos;
	vis[0][0]=1;
	node t,v;
	t.x=0;t.y=0;t.pre=0;t.step=0;
	que[e++]=t;
	while(s<e)
	{
		v=que[s];pos=s;s++;
		if(v.x==4&&v.y==4)
		{
			int tem=pos,p=0;
			for(int i=0;i<=v.step;i++)
			{
				ansx[p]=que[tem].x;ansy[p++]=que[tem].y;
				tem=que[tem].pre;
			}
			for(int i=p-1;i>=0;i--)
			    cout<<"("<<ansx[i]<<", "<<ansy[i]<<")"<<endl;
			return ;
		}
		for(int i=0;i<4;i++)
		{
			t.x=v.x+dir[i][0];
			t.y=v.y+dir[i][1];
			if(0<=t.x&&t.x<5&&0<=t.y&&t.y<5&&!vis[t.x][t.y]&&!ma[t.x][t.y])
			{
				vis[t.x][t.y]=1;
				t.pre=pos;
				t.step=v.step+1;
				que[e++]=t;
			}
		}
	}
}
int  main()
{
	int i,j;
	memset(vis,0,sizeof(vis));
	for(i=0;i<5;i++)
		for(j=0;j<5;j++)
		cin>>ma[i][j];
	bfs();
	return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值