HDU-1013-Digital Roots(Java && 大数 && 数根)

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 57047    Accepted Submission(s): 17799


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
  
  
24 39 0
 

Sample Output
  
  
6 3
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1017  1021  1012  1018  1048 

解释一下题目:
就是给你一个数让你求数的树根!什么叫树根?
比如24这个数的树根,就是把24各个位的数加起来!2+4=6 而且6是个位数,于是它就是24的树根。
然后39这个数一样的方法,3+9=12 此时我们发现12不是个位数,所以它不是数根,继续让它各个
位数相加,1+2=3,3是个位数所以3是39的数根。

数根公式:
a的数根b = ( a - 1) % 9 + 1
还不明白可以百度百科一下数根,很简单的数学定义,简称自然数的一种定义.

import java.io.*;
import java.math.BigInteger;
import java.util.*;

public class Main
{

	public static void main(String[] args)
	{
		// TODO Auto-generated method stub
		Scanner input = new Scanner(System.in);
		while (input.hasNext())
		{
			String num = input.next();
			if (num.equals("0"))
				break;
			BigInteger bigInteger = new BigInteger(num);
			BigInteger Nine = new BigInteger("9");
			BigInteger MinusOne = new BigInteger("-1");
			BigInteger b = bigInteger.add(MinusOne);
			b = b.mod(Nine);
			b = b.add(BigInteger.ONE);
			System.out.println(b);
		}
	}

}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值