HDU-1052-Tian Ji -- The Horse Racing(C++ && 简单贪心)

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21782    Accepted Submission(s): 6374


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
  
  
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
  
  
200 0 0
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1009  1045  1800  1257  1053 


感谢:天 资_WDNLWZD提供的思路与解析:

贪心算法(这里便是列举出了所有最优解得情况):
每次取田忌的最快的马与齐王最快的马比较,有三种情况。
一、田忌最快的马比齐王最快的快,那么直接用田忌最快的马去赢齐王最快的马。
二、田忌最快的马比齐王最快的慢,那么用田忌最慢的马去输齐王最快的马。
三、田忌最快的马与齐王最快的马速度一样。
先用田忌最慢的马与齐王最慢的马比较。
若田忌比齐王快,直接赢掉齐王最慢的马。
否则田忌最慢的马再去与齐王最快的马比较如果最快最慢的马都一样,则忽略掉钱的变化。


#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
    int n,i,j;
    int a[1047],b[1047];
    while(~scanf("%d",&n) && n)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a+1,a+1+n);//田忌的马速度排序
        for(i=1;i<=n;i++)
        {
            scanf("%d",&b[i]);
        }
        sort(b+1,b+1+n);//齐王的马速度排序
        int sum=0;
        int T1,K1;//分别计算田忌和齐王速度慢的马还未使用的当前序号边界
        int T2,K2;//分别计算田忌和齐王速度慢的马还未使用的当前序号边界
        T1=K1=1;
        T2=K2=n;
        for(i=n;i>=1;i--)
        {
            if(a[T2]>b[K2])//如果田忌最快的马比齐王最快的马快直接吃掉
            {
                sum+=200;
                T2--;
                K2--;
            }
            else if(a[T2]<b[K2])//如果田忌最快的马比齐王最快的马慢,用田忌最慢的马去输齐王最快的马
            {
                sum-=200;
                T1++;
                K2--;
            }
            else if(a[T2]==b[K2])//如果双方最快的马速度相同
            {
                if(a[T1]>b[K1])//如果田忌最慢的马比齐王最慢的快,直接吃掉
                {
                    sum+=200;
                    T1++;
                    K1++;
                }
                else if(a[T1]<=b[K1])//如果田忌最慢的马比齐王最慢的马慢或者速度相同
                {
                    if(a[T1]<b[K2])//如果田忌最慢的马比齐王最快的马慢,用最慢的去输齐王最快的
                    {//ps.这里田忌最慢的马不一定比齐王最快的马慢,有可能相等,题目第二个案例
                        sum-=200;
                        T1++;
                        K2--;
                    }
                    else if(a[T1]==b[K2])//双方的马全是一样的速度的情况,那么直接可以忽略掉钱的变化
                    {
                        T1++;
                        K2--;
                    }
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}




 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值