HDU-5310-Souvenir(C++ && 简单数学题)

14 篇文章 0 订阅

Souvenir

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 416    Accepted Submission(s): 270


Problem Description
Today is the 1st anniversary of BestCoder. Soda, the contest manager, wants to buy a souvenir for each contestant. You can buy the souvenir one by one or set by set in the shop. The price for a souvenir is  p  yuan and the price for a set of souvenirs if  q  yuan. There's  m  souvenirs in one set.

There's  n  contestants in the contest today. Soda wants to know the minimum cost needed to buy a souvenir for each contestant.
 

Input
There are multiple test cases. The first line of input contains an integer  T   (1T105) , indicating the number of test cases. For each test case:

There's a line containing 4 integers  n,m,p,q   (1n,m,p,q104) .
 

Output
For each test case, output the minimum cost needed.
 

Sample Input
  
  
2 1 2 2 1 1 2 3 4
 

Sample Output
  
  
1 3
Hint
For the first case, Soda can use 1 yuan to buy a set of 2 souvenirs. For the second case, Soda can use 3 yuan to buy a souvenir.
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5315  5314  5313  5312  5311 


BestCoder官方解析:
1001 Souvenir

本题是一个简单的数学题. 如果套装优惠的话就尽量买套装, 否则单件买. 注意一下如果一直用套装的话可能在最后的零头不如单买好, 即
   
   
    
    (n mod m)p<q
   
   .



#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int t,n,m,p,q;//单价p元,套装q元,一个套装有m个纪念品,总共n个参赛者
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d",&n,&m,&p,&q);
        int price = 0;
        if(q/m<p)//如果套装优惠的话尽量买套装
        {
            if((n%m)*p<q)//如果在买套装最后零头的处理不如单价买便宜
            {
                price = (n/m)*q+(n%m)*p;//就在最后零头买单价
            }
            else
            {
                price = (n/m+1)*q;//否则多买一个套装
            }
        }
        else//否则直接单价买
        {
            price = n*p;
        }

        printf("%d\n",price);
    }
    return 0;
}


中文题目在下面:

 

Souvenir

 
 Accepts: 901
 
 Submissions: 2743
 Time Limit: 2000/1000 MS (Java/Others)
 
 Memory Limit: 262144/262144 K (Java/Others)
问题描述
今天是BestCoder一周年纪念日. 比赛管理员Soda想要给每个参赛者准备一个纪念品. 商店里纪念品的单价是
     
     
      
      p
     
     元, 同时也可以花
     
     
      
      q
     
     元购买纪念品套装, 一个套装里有
     
     
      
      m
     
     个纪念品.

今天总共有
     
     
      
      n
     
     个参赛者, Soda想要知道最少需要花多少钱才可以给每个人都准备一个纪念品.
输入描述
输入有多组数据. 第一行有一个整数
     
     
      
      T
     
      
     
     
      
      (1T105)
     
     , 表示测试数据组数. 然后对于每组数据:

一行包含4个整数 
     
     
      
      n,m,p,q
     
      
     
     
      
      (1n,m,p,q104)
     
     .
输出描述
对于每组数据输出最小花费.
输入样例
2
1 2 2 1
1 2 3 4
输出样例
1
3
Hint
对于第一组数据, Soda可以1元购买一个套装. 对于第二组数据, Soda可以直接花3元购买一个纪念品.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值