HDU-1019-Least Common Multiple( 最大公约数 && 最小公倍数 && GCD )

206 篇文章 0 订阅
78 篇文章 0 订阅

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42833    Accepted Submission(s): 16087


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
  
  
2 3 5 7 15 6 4 10296 936 1287 792 1
 

Sample Output
  
  
105 10296
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1061  1108  1071  1170  1425 


题意:

第一行测试数据个数。
接下来的每行第一个数,作为数列个数(求多少个数的最小公倍数)。

每行对应一个输出。

刚接触编程的那会儿,做过最多的还是这个吧.....最大公约数,最小公倍数,辗转相除法,GCD。

思路:直接求n个数的最小公倍数 a1 a2 a3 a4 ... an先求a1 a2 的最小公倍数temp,再求temp 与a3的最小公倍数,循环下去
因此可以用两个变量a、b存储结果,用temp作为桥梁。当然 代码直接用的long long型,偷懒一点。



#include<iostream>
#include<cstdio>
using namespace std;
long long GCD(long long a,long long b)    //求a,b的最大公约数,GCD公式
{
    if(a<b)
        return GCD(b,a);
    if(b!=0)
        return GCD(b,a%b);
    else
        return a;
}

long long LCM(long long a,long long b)   //求a,b的最小公倍数
{
    return (a*b)/GCD(a,b);
}

int main()
{
    int t,n;
    cin>>t;
    while(t--)
    {
        long long a,b,temp = 1;
        cin>>n;
        for(int i=0;i<n;i++)                //循环求两个数的公倍数
        {
            a = temp;
            cin>>b;
            temp = LCM(a,b);
        }
        cout<<temp<<endl;
    }
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值