LightOJ - 1259 Goldbach`s Conjecture(素数)

原题链接:传送门

Description


Goldbach’s conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:
Every even integer, greater than 2, can be expressed as the sum of two primes[1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input


Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output


For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

	1)Both a and b are prime
	2)a + b = n
	3)a ≤ b

Sample Input


2
6
4

Sample Output


Case 1: 1
Case 2: 1

Note


[1] An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, …


题意:给你一个整数 n,问你存在多少个 a+b = n , 其中 a 和 b 都要是素数,并且 a <= b。
思路: 筛法求素数打个表就可以。。。

#include <bits/stdc++.h>
using namespace std;
const int N = 1e7+1;
bool book[N];
int prime[666666];
int cnt = 0;

void GetPrime(){		//线性筛打表
    memset(book,0,sizeof(book));
    for(int i=2;i<N;i++){
        if(!book[i])
            prime[cnt++] = i;
        for(int j=0;j<N;j++){
            if(i*prime[j] > N)
                break;
            book[i*prime[j]] = 1;
            if(i%prime[j] == 0)
                break;
        }
    }
}

int main(){
    int t,n,Case = 1;
    GetPrime();
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        int sum = 0;
        for(int i=0;i<cnt && prime[i]<n;i++){
            if(prime[i] > n/2)   //由于a <= b,所以只需要判断到n的一半就可以了
                break;
            if(book[n-prime[i]] == 0)
                sum ++;
        }
        printf("Case %d: %d\n",Case++,sum);
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值