POJ 2184 Cow Exhibition

Cow Exhibition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9573 Accepted: 3698

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

Source

USACO 2003 Fall

题意:给出牛的数量、聪明值和有趣值,从这些牛中选出几头使得聪明值和有趣值的和最大。注意:有趣值不能为负数。

01背包,定义dp数组,可以dp[聪明值]=有趣值,而聪明值有正有负,所以让dp数组的下标整体加100000,这样做的话要注意最后取和的时候聪明值减去100000。若聪明值>0,逆序背包,否则,顺序背包,保证每件物品只背一次。

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <string.h>

using namespace std;

const int INF=0x3f3f3f3f;
int n;
int cost[110],weight[110];
int dp[200000];

int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	{
		scanf("%d%d",&cost[i],&weight[i]);
	}
	for(int i=0;i<=200000;i++)
	{
		dp[i]=-INF;
	}
	dp[100000]=0;
	int s=1;
	int t=1;
	for(int i=1;i<=n;i++)
	{
		if(cost[i]>0)//逆序背包
		{
			for(int j=200000;j>=cost[i];j--)
			{
				if(dp[j-cost[i]]>-INF)
				{
					dp[j]=max(dp[j],dp[j-cost[i]]+weight[i]);
					//cout<<dp[j]<<" "<<j<<" "<<"t="<<t++<<endl;
				}
			}
		}
		else//顺序背包,j的范围是0到200000+cost[i],避免j-cost[i]超过200000导致错误,或者初始化时将dp数组开大也可以
		{
			for(int j=0;j<=200000+cost[i];j++)
			{
				if(dp[j-cost[i]]>-INF)
				{
					dp[j]=max(dp[j],dp[j-cost[i]]+weight[i]);
					//cout<<dp[j]<<" "<<j<<" "<<"s="<<s++<<endl;
				}
			}
		}
	}
	int Max=0;
	for(int i=100000;i<=200000;i++)//只有聪明值为非负时dp下标>=100000
	{
		if(dp[i]>=0)
		{
			if(Max<dp[i]+i-100000)
			{
				Max=dp[i]+i-100000;
				//printf("%d %d\n",dp[i],i);
			}
		}
	}
	printf("%d\n",Max);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值