Kindergarten Counting Game


Kindergarten Counting Game
Everybody sit down in a circle. Ok. Listen to me carefully.
``Woooooo, you scwewy wabbit!''
Now, could someone tell me how many words I just said?
Input and Output
Input to your program will consist of a series of lines, each line containing multiple words (at least one). A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).
Your program should output a word count for each line of input. Each word count should be printed on a separate line.
Sample Input
Meep Meep!
I tot I taw a putty tat.
I did! I did! I did taw a putty tat.
Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...
Sample Output
2
7
10
9
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int main()
{
    string str;
    int nWords;

    while(getline(cin,str,'\n'))
    {
        nWords = 0;
        bool isWord =false;
        string::iterator It;
        for( It= str.begin(); It!=str.end() ; ++It)
        {
            if((*It>='a' && *It<='z') || (*It>='A' && *It <='Z') )
            {
                if(!isWord) isWord = true;
            }
            else
            {
                if(isWord){
                    isWord = false;
                    nWords++;
                }
            }
        }
        --It;
        //防止最后的字符是字母时少加一;
        if((*It>='a' && *It<='z') || (*It>='A' && *It <='Z') && isWord)
            nWords++;
        cout<<nWords<<endl;

    }

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值