HDOJ 1019 Least Common Multiple

116 篇文章 0 订阅
27 篇文章 0 订阅

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29468    Accepted Submission(s): 11131


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
  
  
2 3 5 7 15 6 4 10296 936 1287 792 1
 

Sample Output
  
  
105 10296
 

 

 

题意:

求最小公倍数

 

这题要注意a/gcd(a,b)*b;因为a*b可能会超出int的范围!!!!

本题的思路就是:

先求出第一个数和第二个数的最小公倍数,然后再和第三个数求最小公倍数,以此类推

 

 

#include<stdio.h>
int gcd(int a,int b)
{
	int temp;
	while(b)
	{
		temp=a;
		a=b;
		b=temp%b;
	}
	return a;
}
int  main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		int i,N,a,b;
		scanf("%d",&N);
		scanf("%d",&a);
		for(i=1;i<N;i++)
		{
			scanf("%d",&b);
			a=a/gcd(a,b)*b;
		}
		printf("%d\n",a);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值