HDU 1323 Perfection

/*
中文题目    完美
中文翻译-大意  如果这个数的所有因子之和等于这个数,就输出PERFECT,如果所有因子之和小于这个数,就输出DEFICIENT,如果所有因子之和比这个数大就输出ABUNDANT
解题思路:打一个表,求解一个数的所有因子之和
难点详解:用两个for循环求解,注意第二个for循环要的循环条件为i*j<MAXN;才不会超时
关键点:求一个数所有因子的和(不包括自身)
解题人:lingnichong
解题时间:2014-08-25 19:51:32
解题体会:水题
*/


Perfection

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1712    Accepted Submission(s): 1024


Problem Description
From the article Number Theory in the 1994 Microsoft Encarta: "If a, b, c are integers such that a = bc, a is called a multiple of b or of c, and b or c is called a divisor or factor of a. If c is not 1/-1, b is called a proper divisor of a. Even integers, which include 0, are multiples of 2, for example, -4, 0, 2, 10; an odd integer is an integer that is not even, for example, -5, 1, 3, 9. A perfect number is a positive integer that is equal to the sum of all its positive, proper divisors; for example, 6, which equals 1 + 2 + 3, and 28, which equals 1 + 2 + 4 + 7 + 14, are perfect numbers. A positive number that is not perfect is imperfect and is deficient or abundant according to whether the sum of its positive, proper divisors is smaller or larger than the number itself. Thus, 9, with proper divisors 1, 3, is deficient; 12, with proper divisors 1, 2, 3, 4, 6, is abundant." 
Given a number, determine if it is perfect, abundant, or deficient. 
 

Input
A list of N positive integers (none greater than 60,000), with 1 < N < 100. A 0 will mark the end of the list.
 

Output
The first line of output should read PERFECTION OUTPUT. The next N lines of output should list for each input integer whether it is perfect, deficient, or abundant, as shown in the example below. Format counts: the echoed integers should be right justified within the first 5 spaces of the output line, followed by two blank spaces, followed by the description of the integer. The final line of output should read END OF OUTPUT.
 

Sample Input
  
  
15 28 6 56 60000 22 496 0
 

Sample Output
  
  
PERFECTION OUTPUT 15 DEFICIENT 28 PERFECT 6 PERFECT 56 ABUNDANT 60000 ABUNDANT 22 DEFICIENT 496 PERFECT END OF OUTPUT
 

Source
 

#include<stdio.h>
#include<string.h>
#define MAXN 100000
int arr[MAXN];
int main()
{
	printf("PERFECTION OUTPUT\n");
	int n,i,j;
	memset(arr,0,sizeof(arr));
	for(i=1;i<MAXN;i++)
		for(j=1;i*j<MAXN;j++)
			arr[i*j]+=i;
	while(scanf("%d",&n),n)
	{
		
		if(arr[n]-n==n)
			printf("%5d  PERFECT\n",n);
		else if(arr[n]-n>n)
			printf("%5d  ABUNDANT\n",n);
		else if(arr[n]-n<n)
			printf("%5d  DEFICIENT\n",n);
	}
	printf("END OF OUTPUT\n");
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值