HDU 1017 A Mathematical Curiosity【看懂题意+穷举法】

156 篇文章 0 订阅
11 篇文章 0 订阅

//2014.10.17    01:19
//题意:
//先输入一个数N,然后分块输入,每块输入每次2个数,n,m,直到n,m同时为零时 
//结束,当a和b满足题目要求时那么这对a和b就是一组
//注意:
//每一块的输出中间有一个回车 

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27177    Accepted Submission(s): 8651


Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input
  
  
1 10 1 20 3 30 4 0 0
 

Sample Output
  
  
Case 1: 2 Case 2: 4 Case 3: 5
 

Source
 


#include<stdio.h>
int main()
{
    int N;
    int n,m;
    int a,b;
    int cas;
    scanf("%d",&N);
    while(N--)
    {
        cas=1;
        while(scanf("%d%d",&n,&m),n||m)
        {
            int count=0;
            for(a = 1; a < n; a++)//穷举法 
            {
            	for(b = a + 1; b < n; b++)
            	{
                	if((a*a + b*b + m) % (a * b) == 0)
                		count++;
            	}    
        	}
    		printf("Case %d: %d\n",cas++,count);
     	}   	
        if(N)
        	printf("\n");        
    }    
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值