HDU 1228 A + B【字符串的处理】

//对字符串的处理很好

A + B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12172    Accepted Submission(s): 7118


Problem Description
读入两个小于100的正整数A和B,计算A+B.
需要注意的是:A和B的每一位数字由对应的英文单词给出.
 

Input
测试输入包含若干测试用例,每个测试用例占一行,格式为"A + B =",相邻两字符串有一个空格间隔.当A和B同时为0时输入结束,相应的结果不要输出. 
 

Output
对每个测试用例输出1行,即A+B的值.
 

Sample Input
  
  
one + two = three four + five six = zero seven + eight nine = zero + zero =
 

Sample Output
  
  
3 90 96
 

Source
 




#include<stdio.h>
#include<string.h>
char a[10][10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
int fun(char c[])
{
    //if(strcmp(a[0],c)==0)	return 0;
//    if(strcmp(a[1],c)==0)	return 1;
//    if(strcmp(a[2],c)==0)	return 2;
//    if(strcmp(a[3],c)==0)	return 3;
//    if(strcmp(a[4],c)==0)	return 4;
//    if(strcmp(a[5],c)==0)	return 5;
//    if(strcmp(a[6],c)==0)	return 6;
//    if(strcmp(a[7],c)==0)	return 7;
//    if(strcmp(a[8],c)==0)	return 8;
//    if(strcmp(a[9],c)==0)	return 9;
	  int i;
	  for(i=0;i<10;i++)
	  	if(strcmp(a[i],c)==0)
		 return i; 
}    
int main()
{
    char str1[10],str2[10];
    int p,q;
    while(1)
    {
        p=q=0;
        while(scanf("%s",str1) && strcmp(str1,"+")!=0)
        	p=p*10 + fun(str1);
    	while(scanf("%s",str2) && strcmp(str2,"=")!=0)
    		q=q*10 + fun(str2);
		if(p==0&&q==0)
			break;
		else
			printf("%d\n",p+q);
    }    
    return 0;
}     



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值