NYOJ 297 GoroSort(数学题)

45 篇文章 0 订阅
4 篇文章 0 订阅

NYOJ 297 GoroSort

GoroSort

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 4
描述

Goro has 4 arms. Goro is very strong. You don't mess with Goro. Goro needs to sort an array of N different integers. Algorithms are not Goro's strength; strength is Goro's strength. Goro's plan is to use the fingers on two of his hands to hold down several elements of the array and hit the table with his third and fourth fists as hard as possible. This will make the unsecured elements of the array fly up into the air, get shuffled randomly, and fall back down into the empty array locations.

Goro wants to sort the array as quickly as possible. How many hits will it take Goro to sort the given array, on average, if he acts intelligently when choosing which elements of the array to hold down before each hit of the table? Goro has an infinite number of fingers on the two hands he uses to hold down the array.

More precisely, before each hit, Goro may choose any subset of the elements of the array to freeze in place. He may choose differently depending on the outcomes of previous hits. Each hit permutes the unfrozen elements uniformly at random. Each permutation is equally likely.

输入
The first line of the input gives the number of test cases, T. T test cases follow. Each one will consist of two lines. The first line will give the number N. The second line will list the N elements of the array in their initial order.
1 ≤ T ≤ 100;
The second line of each test case will contain a permutation of the N smallest positive integers.
1 ≤ N ≤ 1000;
输出
For each test case, output one line containing "Case #x: y", where x is the case number (starting from 1) and y is the expected number of hit-the-table operations when following the best hold-down strategy. Answers with an absolute or relative error of at most 10-6 will be considered correct.
样例输入
3
2
2 1
3
1 3 2
4
2 1 4 3
样例输出
Case #1: 2.000000
Case #2: 2.000000
Case #3: 4.000000
提示
In test case #3, one possible strategy is to hold down the two leftmost elements first. Elements 3 and 4 will be free to move. After a table hit, they will land in the correct order [3, 4] with probability 1/2 and in the wrong order [4, 3] with probability 1/2. Therefore, on average it will take 2 hits to arrange them in the correct order. After that, Goro can hold down elements 3 and 4 and hit the table until 1 and 2 land in the correct order, which will take another 2 hits, on average. The total is then 2 + 2 = 4 hits.
来源
Google Code Jam 2011 资格赛
上传者
张云聪

参考的博客,一开始没看下去,说的乱七八糟,又是拍桌子,又是好多手,没看明白。看了别人给的翻译,之后又回过头来仔细看了一遍,稍微有点懂了。特别是在看到后面的“温馨提示”,感觉有点思路了。

题目意思就是给出一组数,用手指压住任意一些元素,移动剩下的两个,进行最少的移动次数使得数组从小到大有序。每次移动都有两种可能,按最坏的情况考虑,也就是说互换两个元素的次序都要拍两次桌子。此外,根据题目意思,数据都是从1到N,只不过顺序乱了。


#include<stdio.h>
int main(){
	int T,N,temp = 1;
	scanf("%d",&T);
	while(T--){
		int arr;
		double count = 0;
		scanf("%d",&N);
		for(int i = 1; i <= N; i++){
			scanf("%d",&arr);
			if(i != arr)	count++;
		}	
		printf("Case #%d: %.6lf\n",temp,count);
		temp++;
	}
	
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值