hdu 5228 OO’s Sequence 多校 思维题

点击打开链接

OO’s Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1317    Accepted Submission(s): 467


Problem Description
OO has got a array A of size n ,defined a function f(l,r) represent the number of i (l<=i<=r) , that there's no j(l<=j<=r,j<>i) satisfy a i mod a j=0,now OO want to know
i=1nj=inf(i,j) mod 109+7.

 

Input
There are multiple test cases. Please process till EOF.
In each test case: 
First line: an integer n(n<=10^5) indicating the size of array
Second line:contain n numbers a i(0<a i<=10000)
 

Output
For each tests: ouput a line contain a number ans.
 

Sample Input
  
  
5 1 2 3 4 5
 

Sample Output
  
  
23
 

Author
FZUACM
 

f(l,r)表示l<=i<=r,对任意l<=j<=r,j!=i,i%j!=0,i的个数

求所有f(l,r)之和

开两个数组l[i]和r[i]记录离a[i]最近的是a[i]因数或倍数的下标

由于a[i]小于10000

枚举是a[i]倍数的数就可以

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#define MAXN 111111
#define MOD 1000000007
using namespace std;
int l[MAXN],r[MAXN],pre[MAXN];
int a[MAXN];
int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        memset(pre,0,sizeof(pre));
        for(int i=1;i<=n;i++){
            l[i]=1;
            r[i]=n;
            scanf("%d",&a[i]);
            for(int j=a[i];j<=10000;j+=a[i])
                if(pre[j]!=0&&r[pre[j]]==n)
                    r[pre[j]]=i-1;
                pre[a[i]]=i;
        }
        memset(pre,0,sizeof(pre));
        for(int i=n;i>=1;i--){
            for(int j=a[i];j<=10000;j+=a[i])
                if(pre[j]!=0&&l[pre[j]]==1)
                    l[pre[j]]=i+1;
                pre[a[i]]=i;
        }
        long long ans=0;
        for(int i=1;i<=n;i++)
            ans=(ans+(i-l[i]+1)*(r[i]-i+1))%MOD;
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值