PAT 1001. A+B Format (20)(字符串转换)

题目

1001. A+B Format (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991
提交代码

解题思路

  • 1.先将和转话为字符串,然后利用stack从后往前加上,最后在从堆顶依次输出。

AC代码

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<sstream>
#include<string>
#include<stack>
using namespace std;

int main(int argc, char *argv[])
{
    ios_base::sync_with_stdio(false);
    int a,b,sum;
    cin >> a >> b;
    sum = a + b;
    if (sum<0) {
        //printf("-");
        cout<<"-";
    }
    //将和转化为字符串
    sum = abs(sum);
    string str;
    stringstream ss;
    ss << sum;
    ss >> str;
    int len =str.length();
    //利用stack加入,
    stack<char> keep;
    int cnt = 0;
    while (len--) {
        cnt++;
        keep.push(str[len]);
        if (cnt%3==0) {
            keep.push(',');
        }
    }
    //依次输出
    char out = keep.top();
    if (out==',') {
        keep.pop();
    }
    while (!keep.empty()) {
        char out = keep.top();
        cout << out;
        keep.pop();
    }
    cout << endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值