发放救济金

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counterclockwise up to N (who will be standing on 1’s left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official. 

Input

Writeaprogramthatwillsuccessivelyreadin(inthatorder)thethreenumbers(N, k and m; k,m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0). 

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counterclockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Note: The symbol ⊔ in the Sample Output below represents a space. 

Sample Input 

10 4 3

0 0 0 

Sample Output

␣␣4␣␣8,␣␣9␣␣5,␣␣3␣␣1,␣␣2␣␣6,␣10,␣␣7

---------------------------------------------------------------------------------------------------------------------------------------------------------------

这题大意就是两个人同时数数 被点到的人出列  算是约瑟夫环的升级版 

这题我思路是用两个数组去模拟选人过程 当每轮的人数选定后再同时在两个数组里标记出   一直重复直到所有人出列

---------------------------------------------------------------------------------------------------------------------------------------------------------------

#include <stdio.h>

int main()
{
	int n, k, m;
	while(~scanf("%d %d %d", &n, &k, &m) && n)
	{
		int data1[25] = {0}, data2[25] = {0};
		for(int i = 0; i <= n; i++) { data1[i] = 1; data2[i] = 1; }
		int temp, x = 0, y = 0, pos1 = 1, pos2 = n, flag = 0;
		for( ; ; )
		{
			for( ; ; )
			{
				for(int i = pos1; ; i++)
				{
					if(data1[i]) { x++; } //计算有效次数
					if(x % k == 0 && data1[i])//每次出列的一定是k的倍数
					{
						printf("%3d", i);
						temp = i;
						data1[i] = 0;//0代表出列
						if(i == n) { pos1 = 1; }
						else { pos1 = i + 1;}
						flag = 1;
						break;
					}
					i %= n;
				}
				if(flag) { flag = 0; break; }
			}
			for( ; ; )
			{
				for(int i = pos2; ; i--)
				{
					if(data2[i]) { y++; }//计算有效次数
					if(y % m == 0 && data2[i])
					{
						if(temp != i)
						{ printf("%3d", i); data1[i] = 0; data2[temp] = 0; }//使出列的人在两个数组里都标记上
						data2[i] = 0;
						if(i == 1) { pos2 = n; }
						else { pos2 = i - 1; }
						flag = 1;
						break;
					}
					if(i == 1) { i = n + 1; }
				}
				if(flag) { flag = 0; break; }
			}
			int sum = 0;
			for(int i = 1; i <= n; i++)
			{ if(data1[i] == 0) sum++; }
			if(sum == n) { break; }
			printf(",");
		}
		printf("\n");
	}
	return 0;
 } 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值