搜索入门之“二分查找”&&double运算精度问题-HDU2199

搜索算法是利用计算机的高性能来有目的地穷举一个问题的部分或所有的可能情况,从而求出问题的解的一种方法。

搜索过程实际上是根据初始条件和扩展规则构造一棵解答树并寻找符合目标状态的节点的过程。

包括:二分搜索,三分搜索,DFS,BFS···

今天的主角->二分查找

                                   在给定的若干个(可以很多很多)有序的整数,来查找某个元素是否存在。(强调了二分查找的前提--数据的单调性。)

                                   这类的问题由于牵扯到浮点数的运算,所以要注意精度问题

具体问题具体分析,翠花~上题。

Problem Description
 
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

 
Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 
Output

 

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 
Sample Input
  
  
2 100 -4
 
Sample Output
  
  
1.6152 No solution!
 
//HDOJ-2199
#include <iostream>
#include <cmath>
using namespace std;

double f( double x )
{    
     return 8*pow(x, 4) + 7*pow(x, 3) + 2*pow(x, 2) + 3*x + 6;
}

int main() 
{
    double Y;
    double left, right, mid;
    int t;
    cin>>t; 
    while( t-- ) 
    {
        scanf("%lf", &Y );
        
        if( f(0) <= Y && Y <= f(100) ) {
            
            left = 0;
            
            right = 100;
            
            while( right - left > 1e-6 ) {//用来控制R与L相等时退出
                                          //当差值绝对值小于10的-6次方视作相等                  
                mid = (left + right) / 2;
                
                double ans = f(mid);
                
                if( ans > Y ) {
                    right = mid - 1e-7;//舍去无用的精度 
                }
                else
                    left = mid + 1e-7;
            }
            printf("%.4lf\n", (left + right) / 2 );
        }
        else
            printf("No solution!\n");
    }
}

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值