LOOPS

Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl). 

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS. 


The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)! 
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS. 


 

Input

The first line contains two integers R and C (2 <= R, C <= 1000). 

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces. 

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them). 

You may ignore the last three numbers of the input data. They are printed just for looking neat. 

The answer is ensured no greater than 1000000. 

Terminal at EOF 

 

Output

A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS. 
 

Sample Input

2 2
0.00 0.50 0.50    0.50 0.00 0.50
0.50 0.50 0.00    1.00 0.00 0.00

Sample Output

6.000

题意:就是说一个人在一个R*C的格子上,他一开始在格子的(1,1)上,他最后要走到格子的(R,C),在后面的数据中,会给出他在每一个格子上留在原地、向下、向右走的概率,每走一步需要花费两点代价。要走X步能到达(R,C),要求X的数学期望。

解析:我们不容易正着计算,但是我们可以逆推,我们可以看作从(R,C)点开始向回走,那么对于每个点,可以从三种情况转移过来:

  • ①从(i,j)原地不动
  • ②从(i,j+1)转移而来
  • ③从(i+1,j)转移而来

我们用dp[i][j]表示倒着走到(i,j)所期望的步数,map[i][j][0~2]分别表示,(i,j)时停在原地、向右走、向下走的概率。

那么根据这三种情况,我们就可以列出转移方程:

     dp[i][j]=dp[i][j]*map[i][j][0]+dp[i][j+1]*map[i][j][1]+dp[i+1][j]*map[i][j][2];

经过整理归纳,我们可以得出最后的式子:

    dp[i][j]=(dp[i][j+1]*map[i][j][1]+dp[i+1][j]*map[i][j][2]+2)/(1-map[i][j][0]);
 

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int n,m;
double dp[1005][1005];
double map[1005][1005][4];
int make(double x){
	double temp=x-1;
	if(temp<0.00000){
		temp=-temp;
	}
	if(temp<0.0000001){
		return 1;
	}
	return 0;
}
int main(){
	while(cin>>n>>m){
		memset(dp,0,sizeof(dp));
		memset(map,0,sizeof(map));
		for(int i=1;i<=n;i++){
			for(int j=1;j<=m;j++){
				double x,y,z;
				scanf("%lf%lf%lf",&x,&y,&z);
				map[i][j][0]=x,map[i][j][1]=y,map[i][j][2]=z;
			}
		}
		for(int i=n;i>=1;i--){
			for(int j=m;j>=1;j--){
				if(i==n&&j==m){
					continue;
				}
				if(make(map[i][j][0])){
					continue;
				}
				dp[i][j]=(dp[i][j+1]*map[i][j][1]+dp[i+1][j]*map[i][j][2]+2)/(1-map[i][j][0]);
			}
		}
		printf("%.3lf\n",dp[1][1]);
	}
	return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值