<a target=_blank href="http://acm.hdu.edu.cn/showproblem.php?pid=2082" style="font-weight: normal;"><em><span style="font-size:18px;">http://acm.hdu.edu.cn/showproblem.php?pid=2082</span></em></a>
<a target=_blank href="http://acm.hdu.edu.cn/showproblem.php?pid=2082" style="font-weight: normal;"><em><span style="font-size:18px;">http://acm.hdu.edu.cn/showproblem.php?pid=2082</span></em></a>
找单词
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4026 Accepted Submission(s): 2878
Problem Description
假设有x1个字母A, x2个字母B,..... x26个字母Z,同时假设字母A的价值为1,字母B的价值为2,..... 字母Z的价值为26。那么,对于给定的字母,可以找到多少价值<=50的单词呢?单词的价值就是组成一个单词的所有字母的价值之和,比如,单词ACM的价值是1+3+14=18,单词HDU的价值是8+4+21=33。(组成的单词与排列顺序无关,比如ACM与CMA认为是同一个单词)。
Input
输入首先是一个整数N,代表测试实例的个数。
然后包括N行数据,每行包括26个<=20的整数x1,x2,.....x26.
然后包括N行数据,每行包括26个<=20的整数x1,x2,.....x26.
Output
对于每个测试实例,请输出能找到的总价值<=50的单词数,每个实例的输出占一行。
Sample Input
2 1 1 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 9 2 6 2 10 2 2 5 6 1 0 2 7 0 2 2 7 5 10 6 10 2 10 6 1 9
Sample Output
7 379297
<pre name="code" class="objc" style="text-align: left;"> <pre name="code" class="objc">#include<stdio.h>
#include<string.h>
int c1[60],c2[60];//数组大小要开合适!!! 开始误写成了int c1[30],c2[30];纠结了一下午!!!!!!!!
int a[30];
int main()
{
int N;
scanf("%d",&N);
while(N--)
{
memset(c1,0,sizeof(c1));
memset(c2,0,sizeof(c2));
memset(a,0,sizeof(a));
int i,j,k;
for(i=1;i<=26;++i)
scanf("%d",&a[i]);
for(i=0;i<=a[1];++i)
c1[i]=1,c2[i]=0;
for(i=2;i<=26;++i)
{
for(j=0;j<=50;++j)
for(k=0;k+j<=50&&k<=i*a[i];k+=i)
c2[k+j]+=c1[j];
for(j=0;j<=50;++j)
c1[j]=c2[j],c2[j]=0;
}
int sum=0;
for(i=1;i<=50;++i)
sum+=c1[i];
printf("%d\n",sum);
}
return 0;
}