Equation

题目链接

Equation


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 49    Accepted Submission(s): 18


Problem Description
  
  
Gorwin is very interested in equations. Nowadays she gets an equation like this
x1+x2+x3++xn=n , and here
0xinfor1inxixi+1xi+1for1in1

For a certain n , Gorwin wants to know how many combinations of xi satisfies above condition.
For the answer may be very large, you are expected output the result after it modular m .
 
Input
  
  
Multi test cases. The first line of the file is an integer T indicates the number of test cases.
In the next T lines, every line contain two integer n,m .

[Technical Specification]
1T<20
1n50000
1m1000000000
 
Output
  
  
For each case output should occupies one line, the output format is Case #id: ans, here id is the data number starting from 1, ans is the result you are expected to output.
See the samples for more details.
 
Sample Input
  
  
2 3 100 5 100
 
Sample Output
  
  
Case #1: 2 Case #2: 3
/*
这可以看成是一个完全背包问题,但是由于数字比较多直接DP会超时。其实可以发现数字的种类最多是sqrt(n)级别的。那么就可以把复杂度降到nsqrt(n);
Dp[i][j]代表前i个数字放好之后能组成j的和数是多少。
递推方程是Dp[i][j]=dp[i][j-i]+dp[i-1][j-i]; 表示第i种数字放的时候,前面要么放了i,要么放了i-1
边界条件是dp[i][j]=0 for i < j
Dp[0][0]=1;
所以最后总的复杂度是n*sqrt(n)
*/
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
int n,M,tt;
int dp[50005][305];
int main() {
    //freopen("D://imput.txt","r",stdin);
    int cur=1;
    scanf("%d",&tt);
    while(tt--) {
        scanf("%d%d",&n,&M);
        for(int i=1; i<=n; i++)
            for(int j=1; j*(j+1)/2<=i; j++)
                dp[i][j]=0;
        dp[1][1]=1;
        for(int i=1; i<=n; i++) {
            for(int j=1; j*(1+j)/2<=i&&i+j<=n; j++) {
                dp[i+j][j]=(dp[i+j][j]+dp[i][j])%M;
                if(i+j+1<=n)
                    dp[i+j+1][j+1]=(dp[i+j+1][j+1]+dp[i][j])%M;
            }
        }
        int res=0;
        for(int i=1; i*(i+1)/2<=n; i++) {
            res=(res+dp[n][i])%M;
        }
        printf("Case #%d: %d\n",cur++,res);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值