POJ2299 Ultra-QuickSort

A - Ultra-QuickSort
Time Limit:7000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

/*
Author: 2486
Memory: 3880 KB		Time: 360 MS
Language: G++		Result: Accepted
*/
//序列的逆序数即为交换次数,所以求出该序列的逆序数即可
//采用归并排序的思路进行求解,将他们分分划分为两个部分求解
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=500000+5;
int A[maxn],T[maxn];
int n;
long long cnt;
void merge_sort(int *AA,int x,int y,int *NN)
{
    if(y-x>1)
    {
        int m=x+(y-x)/2;
        int p=x,q=m,i=x;
        merge_sort(AA,x,m,NN);
        merge_sort(AA,m,y,NN);
        while(p<m||q<y)
        {
            if(q>=y||(p<m&&A[p]<=A[q]))NN[i++]=A[p++];//如果其中有一个为空的话,要判断正确,
            else NN[i++]=A[q++],cnt+=m-p;//加入到了NN数组内的数字一定是比没有加入里面的小,因为,NN里面的都是排好序了的。所以m-p即为所求
        }
        for(i=x;i<y;i++)A[i]=NN[i];//将值附过去就可以了
    }
}

int main() {
    while(~scanf("%d",&n),n) {
        cnt=0;
        for(int i=0; i<n; i++) {
            scanf("%d",&A[i]);
        }
        merge_sort(A,0,n,T);
        printf("%I64d\n",cnt);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值