POJ - 3280Cheapest Palindrome-经典区间DP

POJ - 3280
Time Limit: 2000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u

 Status

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers:  N and  M
Line 2: This line contains exactly  M characters which constitute the initial ID string 
Lines 3..  N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.
这道题目我做的时候,真的纠结了半天,想用区间dp吧,但是又怕超内存,但是后来思考发现
好像题目是2000,我理解为了20000,结果一阵哭,但是做题目的时候又遇到麻烦事情了,就是区间
有点搞懵了dp[i][j]代表着[j,i]看着就有点蛋疼,搞了好久才搞定
所以在此提示读者,认真看题,否则后果自负啊
讲解一下代码:
其中dp[i][j]代表着[i,j]这个区间变成回文字符串的最小代价,(本来是[j,i],后来为了大家的方便我帮她改了,让大家能够更好的理解)
dp[i][j]=min(dp[i][j-1]+cost[str[j]-'a'],dp[i+1][j]+cost[str[i]-'a']);
这个的意思是区间dp[i,j]是由dp[i][j-1]或者是dp[i+1][j]变过来的
接着是cost数组的处理 cost[op[0]-'a']=min(a,b);
因为要使代价最小的话,那么当我们面对一个字符的时候是应该删掉它还是应该增加与其位置对应的字符呢
那就要看代价了,所以这里有个小技巧,就是将操作隐藏,不管是你是删掉还是增加,肯定是选择代价小的那个操作
那么我之前取删除与增加的最小值即可
然后是if(str[i]==str[j])dp[i][j]=dp[i+1][j-1];如果str[i]==str[j],那么开头和结尾相等,证明不用进行操作了
因为他们已经匹配成功了我们要做的就是将他从状态中递推过来dp[i][j]=dp[i+1][j-1]+0,就可以了。
/*
Author: 2486
Memory: 16120 KB		Time: 16 MS
Language: G++		Result: Accepted
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=2000+5;
int dp[maxn][maxn];
char str[maxn],op[10];
int cost[30];
int n,m,a,b;
int main() {
    while(~scanf("%d%d",&n,&m)) {
        scanf("%s",str+1);
        for(int i=0; i<n; i++) {
            scanf("%s%d%d",op,&a,&b);
            cost[op[0]-'a']=min(a,b);
        }
        memset(dp,0,sizeof(dp));//其中dp[i][j]代表着[i,j]这个区间
        for(int j=2; j<=m; j++) {
            for(int i=j-1; i>0; i--) {
                if(str[i]==str[j])dp[i][j]=dp[i+1][j-1];
                else dp[i][j]=min(dp[i][j-1]+cost[str[j]-'a'],dp[i+1][j]+cost[str[i]-'a']);
            }
        }
        printf("%d\n",dp[1][m]);
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值