Triangular Pastures-DP(有点像是暴力枚举)

POJ - 1948
Time Limit: 1000MS Memory Limit: 30000KB 64bit IO Format: %I64d & %I64u

 Status

Description

Like everyone, cows enjoy variety. Their current fancy is new shapes for pastures. The old rectangular shapes are out of favor; new geometries are the favorite. 

I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N (3 <= N <= 40) fence segments (each of integer length Li (1 <= Li <= 40) and must arrange them into a triangular pasture with the largest grazing area. Ms. Hei must use all the rails to create three sides of non-zero length. 

Help Ms. Hei convince the rest of the herd that plenty of grazing land will be available.Calculate the largest area that may be enclosed with a supplied set of fence segments. 

Input

* Line 1: A single integer N 

* Lines 2..N+1: N lines, each with a single integer representing one fence segment's length. The lengths are not necessarily unique. 

Output

A single line with the integer that is the truncated integer representation of the largest possible enclosed area multiplied by 100. Output -1 if no triangle of positive area may be constructed. 

Sample Input

5
1
1
3
3
4

Sample Output

692

Hint

[which is 100x the area of an equilateral triangle with side length 4] 
其中为了能够组成一个三角形那么设其三条边为a,b,c,不妨设a>=b>=c,那么b<=(a+b+c)/2;
因为b最大就是无限接近于a,b=sum-a-c,那么sum是不变得,将c减为0,将b->a,那么a+b<=sum,b<=sum/2.
所以只要枚举sum/2以下的边是否存在(其中j代表b,i代表c所以j>=i)
/*
Author: 2486
Memory: 1000 KB		Time: 79 MS
Language: G++		Result: Accepted
*/

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn=40+5;
int n;
int a[maxn];
bool dp[800][800];//dp[i][j]中代表一条边为i,一条边为j的情况是否存在
int main() {
    while(~scanf("%d",&n)) {
        int sum=0;
        for(int i=0; i<n; i++) {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        memset(dp,false,sizeof(dp));
        dp[0][0]=true;
        int Max=-1;
        for(int i=0; i<n; i++) {
            for(int j=sum/2; j>=0; j--) {
                for(int k=j; k>=0; k--) {
                    if((j>=a[i]&&dp[j-a[i]][k])||(k>=a[i]&&dp[j][k-a[i]])) {
                        dp[j][k]=true;
                        int m=sum-j-k;
                        if(dp[j][k]&&(m+j>k)&&(m+k>j)&&(k+j>m)) {
                            double p=(m+j+k)/2.0;
                            int t=(int)(sqrt(p*(p-m)*(p-j)*(p-k))*100);
                            Max=max(Max,t);
                        }
                    }
                }
            }
        }

        printf("%d\n",Max);
    }
    return 0;
}

以下是清晰版
/*
Author: 2486
Memory: 1000 KB		Time: 79 MS
Language: G++		Result: Accepted
*/

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn=40+5;
int n;
int a[maxn];
bool dp[800][800];//dp[i][j]中代表一条边为i,一条边为j的情况是否存在
int main() {
    while(~scanf("%d",&n)) {
        int sum=0;
        for(int i=0; i<n; i++) {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        memset(dp,false,sizeof(dp));
        dp[0][0]=true;
        for(int i=0; i<n; i++) {
            for(int j=sum/2; j>=0; j--) {
                for(int k=j; k>=0; k--) {
                    if((j>=a[i]&&dp[j-a[i]][k])||(k>=a[i]&&dp[j][k-a[i]])) {
                        dp[j][k]=true;
                    }
                }
            }
        }
        int Max=-1;//这里其实就是暴力枚举所有情况,然后检测
        for(int i=sum/2; i>=1; i--) {
            for(int j=i; j>=1; j--) {
                int k=sum-i-j;
                if(dp[i][j]&&(i+j>k)&&(i+k>j)&&(k+j>i)) {
                    double p=(i+j+k)/2.0;
                    int t=(int)(sqrt(p*(p-i)*(p-j)*(p-k))*100);
                    Max=max(Max,t);
                }
            }
        }
        printf("%d\n",Max);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值