ACdream 1213 Matrix Multiplication(矩阵相乘)

Matrix Multiplication

Time Limit: 2000/1000MS (Java/Others)  Memory Limit: 128000/64000KB (Java/Others)
Problem Description
      Let us consider undirected graph G = {V; E} which has N vertices and M edges. Incidence matrix of this graph is N × M matrix A = {a i,j}, such that a i,j is 1 if i-th vertex is one of the ends of j -th edge and 0 in the other case. Your task is to find the sum of all elements of the matrix A TA.
Input
      The first line of the input file contains two integer numbers — N and M (2 ≤ N ≤ 10 000, 1 ≤ M ≤100 000). Then 2*M integer numbers follow, forming M pairs, each pair describes one edge of the graph. All edges are different and there are no loops (i.e. edge ends are distinct).
Output
      Output the only number — the sum requested.
Sample Input
4 4
1 2
1 3
2 3
2 4
Sample Output
18
其实就是一个矩阵,自己乘自己,画图可以秒懂
java:
import java.util.*;
import java.io.*;
import java.math.*;

public class Main{
	static final int MAXN = 10000 + 5;
	static int [] mp = new int[MAXN];
	public static void main(String [] agrv)
	throws IOException
	{
		//System.setIn(new FileInputStream(new File("D:" + File.separator + "imput.txt")));
		Scanner cin = new Scanner(System.in);
		int N, M, u, v;
		while(cin.hasNext()){
			N = cin.nextInt();
			M = cin.nextInt();
			Arrays.fill(mp, 1, N + 1, 0);
			for(int i = 1;i <= M ;i ++){
				u = cin.nextInt();
				v = cin.nextInt();
				if(u == v) mp[v] ++;
				else {
					mp[v] ++;
					mp[u] ++;
				}
			}
			long ans = 0;
			for(int i = 1;i <= N;i ++){
				ans += (long)mp[i] * mp[i];
			}
			System.out.println(ans);
		}
	}
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值