HDU 5763 Another Meaning 多校赛 (DP + KMP)

Another Meaning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1111    Accepted Submission(s): 518


Problem Description
As is known to all, in many cases, a word has two meanings. Such as “hehe”, which not only means “hehe”, but also means “excuse me”. 
Today, ?? is chating with MeiZi online, MeiZi sends a sentence A to ??. ?? is so smart that he knows the word B in the sentence has two meanings. He wants to know how many kinds of meanings MeiZi can express.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each test case contains two strings A and B, A means the sentence MeiZi sends to ??, B means the word B which has two menaings. string only contains lowercase letters.

Limits
T <= 30
|A| <= 100000
|B| <= |A|

 

Output
For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the number of the different meaning of this sentence may be. Since this number may be quite large, you should output the answer modulo 1000000007.
 

Sample Input
  
  
4 hehehe hehe woquxizaolehehe woquxizaole hehehehe hehe owoadiuhzgneninougur iehiehieh
 

Sample Output
  
  
Case #1: 3 Case #2: 2 Case #3: 5 Case #4: 1
Hint
In the first case, “ hehehe” can have 3 meaings: “*he”, “he*”, “hehehe”. In the third case, “hehehehe” can have 5 meaings: “*hehe”, “he*he”, “hehe*”, “**”, “hehehehe”.
 

Author
FZU
 

Source
 


先KMP求出每一个子串在母串中的位置,然后用DP求解答案即可

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;
typedef long long LL;
const int MAXN = 100000 + 5;
const int MAXM = 1000000 + 5;
const int mod = 1000000007;
char A[MAXN], B[MAXM];
int T, nexts[MAXN];
bool vis[MAXN];
LL dp[MAXN];
void Get_Next(int M) {
    int i = 0,j = -1;
    nexts[0] = -1;
    while(i < M) {
        if(j == -1 || B[i] == B[j]) {
            i ++;
            j ++;
            if(B[i] == B[j]) {
                nexts[i] = nexts[j];
            } else {
                nexts[i] = j;
            }
        } else {
            j = nexts[j];
        }
    }
}

void Get_KMP(int N,int M) {
    int i = 0,j = 0;
    while(i < N && j < M) {
        if(j == -1 || B[j] == A[i]) {
            i ++;
            j ++;
        } else {
            j = nexts[j];
        }
        if(j == M) {
            vis[i - 1] = true;
            j = nexts[j];
        }
    }
}
int main() {
    scanf("%d", &T);
    int cas = 1;
    while(T --) {
        scanf("%s%s", A, B);
        memset(vis, false, sizeof(vis));
        int t1 = strlen(A), t2 = strlen(B);
        Get_Next(t2);
        Get_KMP(t1, t2);
        memset(dp, 0, sizeof(dp));
        dp[0] = 1;
        for(int i = 1; i <= t1; i ++) {
            if(vis[i - 1]) dp[i] = dp[i - t2];
            dp[i] = (dp[i] + dp[i - 1]) % mod;
        }
        printf("Case #%d: %lld\n",cas ++,  dp[t1]);
    }
    return 0;
}



  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值