POJ 3258 River Hopscotch (二分 + 最大化最小值 + 模拟双向链表)

River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11592 Accepted: 4992

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di <L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers:  LN, and  M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题意: 有一条河长L,中间N块石头,最多去掉M块,求任意两个石头间最小距离的最大值

第一种代码:
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
const int MAXN = 5e4 + 5;
const int INF = 0x3f3f3f3f;
int A[MAXN];
int L, N, M;
int par[MAXN];
int chi[MAXN];
bool C(int m) {
	int res = 0;
	par[0] = 0;
	for(int i = 1; i <= N; i ++) {
		par[i] = i - 1;
		chi[i - 1] = i;
	}
	chi[N] = N;
	int t = 0;
	while(chi[t] != t) {
		if(par[t] != t && A[t] - A[par[t]] <= m) {
			res ++;
			chi[par[t]] = chi[t];
			par[chi[t]] = par[t];
		}
		if(res > M) return false;
		t = chi[t];
	}

	return true;
}

int main() {
	while(~scanf("%d%d%d", &L, &N, &M)) {
		A[0] = 0;
		for(int i = 1; i <= N; i ++) {
			scanf("%d", &A[i]);
		}
		A[N + 1] = L;
		N ++;
		sort(A, A + N + 1);
		int lb = -1, ub = L;
		while(ub - lb > 1) {
			int mid = (ub + lb) >> 1;
			if(!C(mid)) {
				ub = mid;
			} else {
				lb = mid;
			}
		}
		printf("%d\n", ub);
	}
	return 0;
}


第二种代码:
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
const int MAXN = 5e4 + 5;
const int INF = 0x3f3f3f3f;
int A[MAXN];
int L, N, M;
int par[MAXN];
int chi[MAXN];
bool C(int m) {
	int res = 0, j = 0;
	for(int i = 1; i <= N; i ++) {
		if(A[i] - A[j] <= m) {
			res ++;
		} else {
			j = i;
		}
		if(res > M) return false;
	}
	return true;
}

int main() {
	while(~scanf("%d%d%d", &L, &N, &M)) {
		A[0] = 0;
		for(int i = 1; i <= N; i ++) {
			scanf("%d", &A[i]);
		}
		A[N + 1] = L;
		N ++;
		sort(A, A + N + 1);
		int lb = -1, ub = L;
		while(ub - lb > 1) {
			int mid = (ub + lb) >> 1;
			if(!C(mid)) {
				ub = mid;
			} else {
				lb = mid;
			}
		}
		printf("%d\n", ub);
	}
	return 0;
}

第一种代码更加容易理解,第二种代码则充分的利用了题目中只关联到了相邻两个石子的关系,所以用一个变量表示前面一个石子,另一个变量表示后面那个石子即可

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值