PAT-甲级 1015 Reversible Primes (20分)【素数打表】

1015 Reversible Primes (20分)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

注意就是最小的质数是2,"0"“1”既不是质数也不是合数

 

#include <bits/stdc++.h>
using namespace std;

int isPrime[50005];
void _Prime() {
    isPrime[1] = 1;
    for (int i = 2; i < 50005; i++) {
        if (!isPrime[i]) {
            for (int j = 2 * i; j < 50005; j += i)
                isPrime[j] = 1;
        }
    }
}
int reverse(int n, int m) {
    int res = 0, t = log(n) / log(m);
    while (n) {
        res += n % m * pow(m, t--);
        n /= m;
    }
    return res;
}
int main() {
    int n, m;
    _Prime();
    while (~scanf("%d", & n) && n >= 0) {
        scanf("%d", & m);
        int a = reverse(n, m);
        if (!isPrime[n] && !isPrime[a]) {
            printf("Yes\n");
        } else {
            printf("No\n");
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值