PAT-甲级 ☆1021 Deepest Root (25分)【两次dfs】

1021 Deepest Root (25分)

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

 和二叉树找最深结点的区别是,这是个图,根节点是不固定的。
比如案例

5
1 2
1 3
1 4
2 5

如图所示,

如果从1开始遍历,最深结点是5;

如果从3开始遍历,最深结点是5;如果从4开始遍历,最深结点是5。

如果从5开始遍历,最深结是3和4。

所以答案就是以上所有所有情况的并集:{3,4,5}

事实上,最深根节点是最长路径的起点和终点。

所以就有了如下代码,用两次dfs,

第一次dfs,目的是判断有几个连通块,然后找出一端最远的结点。

第二次dfs,根据这一端,找出另一端。

学习博客:https://blog.csdn.net/Duck_Duck_/article/details/100041421

#include <bits/stdc++.h>
using namespace std;
int n;
vector<int> v[10005], temp;
set<int> s, ans;
int vis[10005], high[10005];
int maxHigh = -1;
void dfs(int t, int h)
{
    if (h > maxHigh) {
        maxHigh = h;
        temp.clear();
        temp.push_back(t);
    } else if (h == maxHigh) {
        temp.push_back(t);
    }
    vis[t] = 1;
    for (int i = 0; i < v[t].size(); i++) {
        if (!vis[v[t][i]])
            dfs(v[t][i], h + 1);
    }
}
int main()
{
    scanf("%d", &n);
    for (int i = 0; i < n - 1; i++) {
        int a, b;
        scanf("%d %d", &a, &b);
        v[a].push_back(b);
        v[b].push_back(a);
    }

    int cnt = 0, k;
    for (int i = 1; i <= n; i++) {
        if (!vis[i]) {
            cnt++;
            dfs(i, 0);
            if (i == 1) {
                for (int j = 0; j < temp.size(); j++) {
                    s.insert(temp[j]);
                }
                if (temp.size() != 0)
                    k = temp.back();
            }
        }
    }
    if (cnt != 1) {
        printf("Error: %d components", cnt);
        return 0;
    }
    temp.clear();
    maxHigh = -1;
    memset(vis, 0, sizeof(vis));
    dfs(k, 0);
    for (int j = 0; j < temp.size(); j++) {
        s.insert(temp[j]);
    }
    for (auto it = s.begin(); it != s.end(); it++) {
        printf("%d\n", *it);
    }
    system("pause");
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值