PTA 6-13 在一个数组中实现两个堆栈 (20 分)

本题要求在一个数组中实现两个堆栈。

函数接口定义:

Stack CreateStack( int MaxSize );
bool Push( Stack S, ElementType X, int Tag );
ElementType Pop( Stack S, int Tag );

其中Tag是堆栈编号,取1或2;MaxSize堆栈数组的规模;
Stack结构定义如下:

typedef int Position;
struct SNode {
    ElementType *Data;
    Position Top1, Top2;
    int MaxSize;
};
typedef struct SNode *Stack;

注意:如果堆栈已满,Push函数必须输出“Stack Full”并且返回false;如果某堆栈是空的,则Pop函数必须输出“Stack Tag Empty”(其中Tag是该堆栈的编号),并且返回ERROR。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

#define ERROR 1e8
typedef int ElementType;
typedef enum { push, pop, end } Operation;
typedef enum { false, true } bool;
typedef int Position;
struct SNode {
    ElementType *Data;
    Position Top1, Top2;
    int MaxSize;
};
typedef struct SNode *Stack;

Stack CreateStack( int MaxSize );
bool Push( Stack S, ElementType X, int Tag );
ElementType Pop( Stack S, int Tag );

Operation GetOp();  /* details omitted */
void PrintStack( Stack S, int Tag ); /* details omitted */

int main()
{
    int N, Tag, X;
    Stack S;
    int done = 0;

    scanf("%d", &N);
    S = CreateStack(N);
    while ( !done ) {
        switch( GetOp() ) {
        case push: 
            scanf("%d %d", &Tag, &X);
            if (!Push(S, X, Tag)) printf("Stack %d is Full!\n", Tag);
            break;
        case pop:
            scanf("%d", &Tag);
            X = Pop(S, Tag);
            if ( X==ERROR ) printf("Stack %d is Empty!\n", Tag);
            break;
        case end:
            PrintStack(S, 1);
            PrintStack(S, 2);
            done = 1;
            break;
        }
    }
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:
5
Push 1 1
Pop 2
Push 2 11
Push 1 2
Push 2 12
Pop 1
Push 2 13
Push 2 14
Push 1 3
Pop 2
End
输出样例:
Stack 2 Empty
Stack 2 is Empty!
Stack Full
Stack 1 is Full!
Pop from Stack 1: 1
Pop from Stack 2: 13 12 11

阿伟读完题后一脸懵逼,一开始以为两头都是栈顶,,,经大佬提点之后才知道两头应该都是栈底。课本上栈的数组描述也是用的索引为0的位置是栈底emmm
那这样就简单多了,在CreateStack函数中,为了之后好判断,将Top1设为-1,Top2设为MaxSize,由于编译器是C的,所以在动态申请空间的时候不能用new,要用到malloc函数,具体动态申请数组空间的代码为:

s->Data=(int *)malloc(MaxSize*sizeof(int));//MaxSize为数组大小

在push函数中,重要的就是数组是否满了的判断,如果Top1+1==Top2,则证明数组栈已经满了
在pop函数中(这个函数最气人),读题发现我并不知道如果删除成功后我要返回什么。。之后翻看了大佬的代码,才知道如果删除成功要返回删除的(之前的)栈顶元素(太气人了,手动拍桌)

(还要感谢大佬补全了题目中没给的两个函数)

Operation GetOp()
{
    char Push[] = "Push";
    char Pop[] = "Pop";
    char End[] = "End";
    char s[100];
    scanf("%s", s);

    if (strcmp(Push, s) == 0)return push;
    if (strcmp(Pop, s) == 0)return pop;
    if (strcmp(End, s) == 0)return end;
}
void PrintStack(Stack S, int Tag)
{
    printf("Pop from Stack %d:", Tag);
    if (Tag == 1){
        while (S->Top1 != -1){
            printf(" %d", S->Data[S->Top1--]);
        }
    }
    else {
        while (S->Top2 != S->MaxSize){
            printf(" %d", S->Data[S->Top2++]);
        }
    }
    putchar('\n');
}

阿伟的AC代码:

Stack CreateStack( int MaxSize )
{
    Stack s=(Stack)malloc(sizeof(struct SNode));
    s->Data=(int *)malloc(MaxSize*sizeof(int));
    s->Top1=-1;
    s->Top2=MaxSize;
    s->MaxSize=MaxSize;
    return s;
}
bool Push( Stack S, ElementType X, int Tag )
{
    if(S->Top1+1==S->Top2)
    {
        printf("Stack Full\n");
        return false;
    }
    if(Tag==1)
    {
        S->Data[++S->Top1]=X;
    }
    else
        S->Data[--S->Top2]=X;
    return true;
}
ElementType Pop( Stack S, int Tag )
{
    if((Tag==1&&S->Top1==-1)||(Tag==2&&S->Top2==S->MaxSize))
    {
        printf("Stack %d Empty\n",Tag);
        return ERROR;
    }
    if(Tag==1)
        return S->Data[S->Top1--];//返回新的栈顶元素
    else
        return S->Data[S->Top2++];
    return 1;
}
  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值