简单的类似斐波那契问题,也就是递推问题
Problem Description
有一头母牛,它每年年初生一头小母牛。每头小母牛从第四个年头开始,每年年初也生一头小母牛。请编程实现在第n年的时候,共有多少头母牛?
Input
输入数据由多个测试实例组成,每个测试实例占一行,包括一个整数n(0 < n < 55), n的含义如题目中描述。
n=0表示输入数据的结束,不做处理。
Output
对于每个测试实例,输出在第n年的时候母牛的数量。
每个输出占一行。
Sample Input
2
4
5
0
Sample Output
2
4
6
AC代码:
#include <iostream>
#include <string>
#include <vector>
#include <cctype>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
int a[55];
int main()
{
int n;
a[1] = 1; a[2] = 2; a[3] = 3;
for (int i = 4; i < 55; i++)
a[i] = a[i - 3] + a[i - 1];
while (true)
{
cin >> n;
if (n == 0) break;
cout << a[n] << endl;
}
return 0;
}