母牛的故事

简单的类似斐波那契问题,也就是递推问题
Problem Description
有一头母牛,它每年年初生一头小母牛。每头小母牛从第四个年头开始,每年年初也生一头小母牛。请编程实现在第n年的时候,共有多少头母牛?

Input
输入数据由多个测试实例组成,每个测试实例占一行,包括一个整数n(0 < n < 55), n的含义如题目中描述。

n=0表示输入数据的结束,不做处理。

Output
对于每个测试实例,输出在第n年的时候母牛的数量。
每个输出占一行。

Sample Input
2
4
5
0

Sample Output
2
4
6

AC代码:

#include <iostream>
#include <string>
#include <vector>
#include <cctype>
#include <cmath>
#include <cstring>
#include <algorithm>

using namespace std;
int a[55];
int main()
{
    int n;
    a[1] = 1; a[2] = 2; a[3] = 3;
    for (int i = 4; i < 55; i++)
        a[i] = a[i - 3] + a[i - 1];
    while (true)
    {
        cin >> n;
        if (n == 0) break;
        cout << a[n] << endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值