ACM输入与输出

由于ACM题目的输入输出数据不定,格式多种多样,且要求严格,因此,如何处理题目的输入与输出至关重要。


(一)第一类输入:输入不说明有多少个Input Block,以EOF为结束标志。

Example1:
Calculate A + B .
Input:Each line will contain two integers A and B . Process to end of file.
Output:For each case, output A + B in one line.
Sample Input
1 1
2 2
Sample Output
2
4


C语言代码
#include < stdio.h >
int main()
{
     int a,b;
     scanf("%d %d",&a, &b);
     printf("%d\n",a+b);
     return 0;
}


C++语言代码

#include < iostream >
using namespace std;
int main()
{
     int a,b;
     cin >> a >> b;
     cout << a+b << endl;
     return 0;
}



(二)第二类输入:题目告诉有N个Input Block,下面接着是N个Input Block。

Example2:
Problem Description
Your task is to Calculate a + b.
Input:
Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line.
Output:
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
Sample Input:
2
1 5
10 20
Sample Output:
6
30

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值